Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #6861  
Old 03-19-2017, 04:27 PM
ryancassidy ryancassidy is offline
TT Enthusiast
 
Join Date: Aug 2016
Boat: 2017 X10
Location: Southeast
Posts: 487
No pictures yet.... but took delivery on my 2017 x10 on weds PM.

Installed new speaker LED rings and switch
Upgraded rear blast bags to the larger wakemakers.
Installed new dual battery charger
Replaced the M400 with a M800 amp.
Installed an OJ815 prop.

Still have the docking lights and the fender clips to install. More to come (and pictures )
Reply With Quote
  #6862  
Old 03-19-2017, 04:54 PM
Yooper Yooper is offline
TT Enthusiast
 
Join Date: Aug 2016
Boat: 2014 ProStar
Location: Midwest
Posts: 102
I turned the battery tender switch on.
Reply With Quote
  #6863  
Old 03-19-2017, 10:27 PM
81SNS 81SNS is offline
TT Enthusiast
 
Join Date: Aug 2011
Boat: 09 X2
Location: southeast
Posts: 287
Installed my batteries, checked out the amp I installed last weekend, and changed all ballast pump impellers to the newer green impellers, I wanted to flip the pump motors but I don't think there was room where the motor would be sticking up from hitting the angle on the inner transom.
Reply With Quote
  #6864  
Old 03-19-2017, 10:42 PM
Olaff's Avatar
Olaff Olaff is offline
MC Fanatic
 
Join Date: Jul 2014
Boat: 2001 Prostar 205V. 1982 S&S Powerslot (sold).
Location: SE Texas
Posts: 860
I put some fresh 92 octane, put the hull plug in, and went for a ride all afternoon with the wife and kids. Nothing else needed!
Lake is 72 degrees, air 82 degrees.
Reply With Quote
  #6865  
Old 03-19-2017, 11:20 PM
orbeamlb's Avatar
orbeamlb orbeamlb is offline
MC Devotee
 
Join Date: Feb 2012
Boat: 1988 ProStar 200, 1991 Mercury 2.5L 200hp XRi Outboard
Location: Austin, Texas
Posts: 1,284
Pulled off the cover, hooked it up to the Suburban, wiped it down, ran on the muffs then took a 45 mile cruise on Lake Austin.
__________________
Mike B
Reply With Quote
  #6866  
Old 03-20-2017, 05:12 PM
jmstu76 jmstu76 is offline
TT Regular
 
Join Date: Jun 2016
Boat: 1997 Prostar 205 Sammy Duvall
Location: Midwest
Posts: 51
Re ran all new air guide speedo tubing. Hooked up the 12v power to the heater switch. Had all the metal vents powdercoated. Replaced both backing plates on the trailer, new soft lines and new hard line. New UPF A-60 master cylinder.
__________________
James

[email protected]
Reply With Quote
  #6867  
Old 03-20-2017, 05:43 PM
paintpollz's Avatar
paintpollz paintpollz is offline
MC Devotee
 
Join Date: Oct 2014
Boat: 2002 Prostar 197
Location: Fort Worth
Posts: 1,077
Quote:
Originally Posted by orbeamlb View Post
Pulled off the cover, hooked it up to the Suburban, wiped it down, ran on the muffs then took a 45 mile cruise on Lake Austin.
Sounds awesome. Hammer down!
__________________
Kevin
Reply With Quote
  #6868  
Old 03-22-2017, 04:38 AM
PNB MasterCraft PNB MasterCraft is offline
TT Newbie
 
Join Date: Jan 2017
Boat: x10, 2015, Ilmor 5,7
Location: Mid - Germany
Posts: 28
- Did a clean up of the tower and put some wd 40 to all aluminum parts.

- Removed the bimini cover for a cleaning.

Nicolai
Attached Images
 
Reply With Quote
  #6869  
Old 03-23-2017, 07:26 PM
supreme112279 supreme112279 is offline
TT Enthusiast
 
Join Date: Apr 2013
Boat: 1996 mastecraft maristar 225
Location: southeast
Posts: 458
Installed new tower speakers
Krypt 7.7 with new cans

Reply With Quote
  #6870  
Old 03-23-2017, 07:27 PM
supreme112279 supreme112279 is offline
TT Enthusiast
 
Join Date: Apr 2013
Boat: 1996 mastecraft maristar 225
Location: southeast
Posts: 458
New rack for the tower that will hold a kneeboard and a wake board

Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:13 PM.