Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1361  
Old 02-29-2012, 07:51 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 17,246
Send a message via Skype™ to mikeg205
wow...great job
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #1362  
Old 02-29-2012, 08:56 PM
toobusylivin toobusylivin is offline
TT Regular
 
Join Date: Jan 2012
Boat: 1985 stars and stripes power slot
Location: Midwest
Posts: 42
great job!! Love our stars and stripes. Classics!!
Reply With Quote
  #1363  
Old 02-29-2012, 09:42 PM
SkiDog's Avatar
SkiDog SkiDog is offline
MC Addict
 
Join Date: Jun 2005
Boat: 92 Prostar
Location: South of North
Posts: 7,376
My first attempt at upholstery work. The color doesn't match as well as I hoped, so I may redo it in red. Still got another piece to add to the top part, but I'm having it embroidered.
Attached Images
  
Reply With Quote
  #1364  
Old 02-29-2012, 09:46 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 17,246
Send a message via Skype™ to mikeg205
looks great.... color match is tough... before you change...look at it in sunlight...it may look closer in color...as opposed to fluorescent and flash. Look very close on my screen.
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #1365  
Old 03-05-2012, 12:37 AM
gweaver gweaver is offline
MC Devotee
 
Join Date: Aug 2011
Boat: 2003 VRS 230 w/X-boat package, 8.1L
Location: Northern California
Posts: 1,181
Finally addressed the torn shaft log hose. Replaced that with hose that was less than ideal, but hope it'll work until I can get the right stuff. Replaced the shaft packing too. Got the battery back in the boat, started it, verified that the alternator is charging the battery. (Last time I had it out, boat died, battery wouldn't start it, had to get towed back in.) Should be ready for a wet test next weekend.
Think I've dealt with most/all of the mechanical issues, now it's mostly cosmetic stuff to address.
G
Reply With Quote
  #1366  
Old 03-05-2012, 09:40 AM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
 
Join Date: Jun 2007
Boat: 2002 X Star
Location: Lake Tuscaloosa, AL
Posts: 2,337
It took most of the morning to replace the shaft packing, then changed the impellor, fixed an oil leak and changed the oil.
__________________
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote
  #1367  
Old 03-05-2012, 10:26 AM
DemolitionMan's Avatar
DemolitionMan DemolitionMan is offline
MC Devotee
 
Join Date: Jul 2004
Boat: 2008 Pro Star 197 TT #58 of 100
Location: South of the sweet tea line
Posts: 4,290
Quote:
Originally Posted by SkiDog View Post
My first attempt at upholstery work. The color doesn't match as well as I hoped, so I may redo it in red. Still got another piece to add to the top part, but I'm having it embroidered.
Nice looking work there Eddie.
__________________
Automatic doors make me feel like a Jedi
Reply With Quote
  #1368  
Old 03-05-2012, 10:48 AM
SkiDog's Avatar
SkiDog SkiDog is offline
MC Addict
 
Join Date: Jun 2005
Boat: 92 Prostar
Location: South of North
Posts: 7,376
Quote:
Originally Posted by DemolitionMan View Post
Nice looking work there Eddie.
Once I get the embroidery piece back and installed, it'll look 10X better I think.
Reply With Quote
  #1369  
Old 03-05-2012, 02:14 PM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 2,364
On my 205, I had some cavitation burn on my rudder from a slight ding in my prop. I pulled the fuel tank to get to the rudder, pulled the prop and rudder and sent them to Eric and then went to work on the fuel sending unit.

I had some irregular readings from the fuel gauge, so I decided to take a look inside the sender. Sure enough, one of the magnets was out of the foam. I followed this thread for the repair: http://mastercraft.com/teamtalk/showthread.php?t=31039

I'm looking forward to getting this thing back on the water.
Reply With Quote
  #1370  
Old 03-06-2012, 09:30 PM
learjet2230's Avatar
learjet2230 learjet2230 is offline
TT Enthusiast
 
Join Date: Dec 2007
Boat: 1988 Mastecraft Prostar 190, Powerslot, 351 Windsor
Location: Granbury, TX
Posts: 461
Took the boat out of the lift and put it on the trailer...Contacted the powdercoat guy about getting some pieces done...will pull the interior this week to get to the upholstery shop....carpet while that is out.....and had lots of rum!
__________________
1988 PS190 Powerslot, INDMAR 351W, Edelbrock Intake, MSD Ignition,
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:28 AM.