Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 10-14-2017, 10:22 AM
Reedus Reedus is offline
TT Enthusiast
 
Join Date: Mar 2017
Boat: 2015 X23 7.4l
Location: Southwest
Posts: 125
2015 X23 issues :(

I've had the boat for a couple weeks now and the seller claimed 9/10 is total crap. My fault for not doing my due diligence. Biggest issue so far is the Murphy touch screen. It has a mind of it own and will randomly switch profiles, empty/fill ballasts, turn on and off the fusion stereo, and freeze up so no touchscreen buttons respond. It's so bad it's frustrating to even be on the lake. Yesterday for the second time, the 7.4l motor wouldn't start randomly. It will crank and crank, but not fire. First time it took about 3 key cycles/cranking to get it to finally start. Yesterday it was a solid 15 minutes of cranking every couple minutes before it started. This is after having it run for a couple of hours with no issue. Anybody with the 7.4l had this issue? The passenger flip up seat has stitching coming undone underneath from how it closes against adjacent coffin storage seat. Glove box latch won't keep door closed. Any bump and it pops open. And now I've got trailer light gremlins to track down as I'm missing a rear brake light that comes and goes
Reply With Quote
  #2  
Old 10-14-2017, 10:32 AM
WakeRider107 WakeRider107 is offline
TT Enthusiast
 
Join Date: Feb 2012
Boat: boat
Location: location
Posts: 155
Did you transfer the warranty?
Reply With Quote
  #3  
Old 10-14-2017, 10:33 AM
ryancassidy ryancassidy is offline
MC Fanatic
 
Join Date: Aug 2016
Boat: 2017 X10
Location: Southeast
Posts: 519
So I have to ask.... Do you have any of the 5 year Mastercare warrenty left? I'm assuming not...

I can be of no assistance in fixing those issues.. Its a bummer, you have a great boat!! RE Motor: How many hours are on it? I wonder if it just needs a solid go?
Reply With Quote
  #4  
Old 10-14-2017, 10:34 AM
XC500mod XC500mod is offline
MC Fanatic
 
Join Date: Sep 2015
Boat: '18 x23, '15 x10
Location: Upper Midwest
Posts: 691
Are you the second or third owner? If you’re the second, make sure you transferre the warranty. Take it to a dealer and have them fix these problems under warranty. I had a ‘15 with computer gremlins and an update fixed that.
Reply With Quote
  #5  
Old 10-14-2017, 10:34 AM
wallnut21 wallnut21 is offline
TT Enthusiast
 
Join Date: Aug 2013
Boat: 2018 MasterCraft X23
Location: Tablerock
Posts: 460
All warranty. Software update should solve touchscreen. 7.4 issues have been documented on here, not sure if issues were resolved. I had the glove box problem too. Replaced latch and it seems to be fixed.
Reply With Quote
  #6  
Old 10-14-2017, 10:45 AM
JohnE's Avatar
JohnE JohnE is offline
Moderator
 
Join Date: Jan 2006
Boat: XT22
Location: Boston 'burbs
Posts: 11,784
As mentioned, the 5 year warranty is a huge benefit. Hopefully you can or did transfer it.
__________________
Prior boats - (3) X14's, (3) Prostars, and a Tristar.
Reply With Quote
  #7  
Old 10-14-2017, 10:52 AM
Reedus Reedus is offline
TT Enthusiast
 
Join Date: Mar 2017
Boat: 2015 X23 7.4l
Location: Southwest
Posts: 125
Warranty transfer request was sent to corporate last week, just waiting for approval. I guess my frustration lies in that this was supposed to be a turn-key purchase. Far far from that. I hate turning this boat over to the dealer when it still 95 degrees outside
Reply With Quote
  #8  
Old 10-14-2017, 10:55 AM
Reedus Reedus is offline
TT Enthusiast
 
Join Date: Mar 2017
Boat: 2015 X23 7.4l
Location: Southwest
Posts: 125
Quote:
Originally Posted by ryancassidy View Post
So I have to ask.... Do you have any of the 5 year Mastercare warrenty left? I'm assuming not...

I can be of no assistance in fixing those issues.. Its a bummer, you have a great boat!! RE Motor: How many hours are on it? I wonder if it just needs a solid go?
Motor has 130 hrs...
Reply With Quote
  #9  
Old 10-14-2017, 11:08 AM
WhiskeyTango WhiskeyTango is offline
TT Regular
 
Join Date: Apr 2015
Boat: 2015 X30
Location: Great Plains
Posts: 66
The problems with your screen will likely require replacement. Mastercraft calls this "ghost touch" and it's the result of a manufacturing defect. I argued with my dealer for months and did several software updates, replaced the starter button, tried a different engine management module (not sure of the technical name), etc before they finally got Mastercraft involved. I talked to the Mastercraft guy directly and he said that it is a known, but not common, issue.

The screen should be a warranty item. I was tired of dragging the boat back and forth from the lake to the dealer, so I changed the screen myself. It's a very simple, 30 minute job to change and it fixed all of my issues. I've put over 100 hours on the boat since.

Keep your chin up. You'll love it once this is fixed.
Reply With Quote
  #10  
Old 10-14-2017, 02:00 PM
markmcfarland's Avatar
markmcfarland markmcfarland is offline
MC Devotee
 
Join Date: Jul 2013
Boat: 2013 X-Star 2009 X-Star (SOLD) 2003 X2 (SOLD)
Location: Kentucky
Posts: 1,472
On the 7.4 issue I THINK that the short term remedy was to start it with the throttle all the way down. Think it was a back pressure issue. They have some kinda fix that the dealer does. There is a thread on hear about it. I would definitely search for the thread before you do what I said.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:04 AM.


2018