Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 05-08-2018, 11:36 AM
2006x15 2006x15 is offline
TT Newbie
 
Join Date: May 2018
Boat: Mastercraft x15 2006 mcx 350 5.7
Location: Northwest
Posts: 1
Question 2006 x15 mcx 5.7 crank position sensor misfire

Hello,

This is my first post and know that this problem may have already been discussed in the past but I couldn't find a definite answer anywhere.

I have a 2006 x15 with a mcx 5.7 350, this my 3rd season with it and never had a problem but replaced the fuel pump.
I started having misfiring since last season and purchased a code reader. Pulled codes and came up with crank position sensor. I went and bought an oem ac delco one and fixed the problem. After about 1 the problem came back but would only misfire and put me into limp mode after 4k rpm or 35mph.

Since then the problem has worsened, I just changed cap and rotor, spark plugs, and oil. Cap and rotor were pretty beat up and spark plugs pretty used. I also ordered new wires but still waiting on them. I took the boat out yesterday and I seemed that the problem had been fixed but after about 10 min of wot it started misfiring and check engine kicked in and behold limp mode.

Pulled codes and again crank position sensor. As stated earlier I just bought this last season. Paid $130 for it and it's the oem gm one.

Any suggestions help I appreciate it in advance and sorry for long description.
Reply With Quote
Reply

Tags
crank position sensor, limp mode, misfire, x15, x30

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:49 AM.


2018