Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 10-10-2017, 11:32 AM
tjrowbot's Avatar
tjrowbot tjrowbot is offline
TT Enthusiast
 
Join Date: Sep 2017
Boat: 2000 X5
Location: The Mitten
Posts: 153
2000 X5 Engine Ground

Purchased a 2000 X5 late summer and starting to work on the issues I have found with the boat. The PO didn't take exceptional care of the boat, but did all proper maintenance. Upon changing the oil for winterization I found a random wire & cover which looks to be a ground. The only thing is I cannot trace it back anywhere. Can anyone point out where this should go?

BTW- brand new to TT, although I have stalked this site for years. I am reworking the entire boat as I probably overpaid for it, and am going to make it my baby. I have tons of questions which I can't find in the discussions / threads / posts.
Attached Images
 

Last edited by tjrowbot; 10-10-2017 at 11:50 AM.
Reply With Quote
  #2  
Old 10-10-2017, 04:23 PM
curver900 curver900 is offline
MC Devotee
 
Join Date: Aug 2013
Boat: Mastercraft, prostar 2001 205v
Location: midwest
Posts: 2,410
That boat better get out and thank you daily for getting rid of that fram filter and putting on a WIX..

Some wires just don't go anywhere.. put the key in the on position and put a volt meter on it and see if it reads anything or put it on continuity and see if it is a ground...

while in there replace the cap/rotor/plugs and wires... they are original..

another opportunity is to check the battery cables usually at this age they are in rough shape and preventative replacement now keeps things good next year...
Reply With Quote
  #3  
Old 10-10-2017, 05:39 PM
airwear's Avatar
airwear airwear is offline
TT Enthusiast
 
Join Date: Sep 2004
Boat: 2000 Mastercraft Prostar 195 - LTR, ZeroFlex Tower
Location: Toronto, Ontario
Posts: 118
What engine is in the X5. I have a 2000 Prostar 195 with LTR engine. I can look at mine and tell you, however, I will not be near my boat for another few weeks.
Reply With Quote
  #4  
Old 10-10-2017, 10:50 PM
tjrowbot's Avatar
tjrowbot tjrowbot is offline
TT Enthusiast
 
Join Date: Sep 2017
Boat: 2000 X5
Location: The Mitten
Posts: 153
Thank you for the suggestions. The engine is the predator 310hp tbi. Any information is appreciated. I plan to swap out the wires from the plugs to the battery. I have read numerous posts about what to use so I'll spare you that question of what you prefer.
Reply With Quote
  #5  
Old 10-10-2017, 11:08 PM
wheelerd's Avatar
wheelerd wheelerd is offline
MC Devotee
 
Join Date: Dec 2007
Boat: 2005 X2
Location: Central Alberta, Canada
Posts: 1,880
I had an 01 X5 so bring on the questions.
__________________
2005 X2, Viper Red, MCX, OJ TZ-X5 prop, PPass, rear 750 sacs, KBS, IBS, Bennett Wake Plate, custom wake shaper
(previous) 2001 X5, 1991 TriStar 190
Reply With Quote
Reply

Tags
engine, ground, loose wire

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:38 PM.


2018