Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #21  
Old 05-20-2018, 09:54 AM
2RLAKE's Avatar
2RLAKE 2RLAKE is offline
MC Maniac
 
Join Date: Jun 2007
Boat: '13 x10 with 6.0 and '93 25th Anniversary Limited Edition
Location: Cincinnati OH & Lake Norris TN
Posts: 4,801
Quote:
Originally Posted by PeterAK View Post






Lov e that picture!
Reply With Quote
  #22  
Old 05-24-2018, 03:40 PM
PeterAK PeterAK is offline
TT Newbie
 
Join Date: Jun 2017
Boat: 1992 Prostar 190
Location: Wisconsin
Posts: 26
Thanks for all the comments! Please keep the feedback coming.

Last night I finally had some time to start working on the boat. New roller went on the trailer, cut some treated plywood slabs to protect my asphalt driveway, got the drain plug out (easily!) after a 24 hour soak with PB Blaster, and lubed the latch on the trailer.



Took a closer look at the bend in the end piece of the boom. I don't see any cracks near the bend. Guessing it is still not a good idea to use it, is that right?


Spent some time eyeballing the drive line after reading some threads here about dealing with vibrations. The boat has a minor vibration when getting up to speed. Nothing when idling in gear or at speed. Looks like the cutlass bearing needs to be replaced, and at the very least, I need to do an alignment. Since it is lake season, I'm thinking I'll try to align it now so I can get on the water, and order the bearing now so that I can take on that job when I have more time. Given the way the drive shaft rides in the cutlass bearing and the side to which the drive shaft goes through the hole in the hull, I'm hoping that I'll be able to get it aligned, but I am a bit concerned that the strut may be bent. To my untrained eye it looks straight, but the way the drive shaft is wearing the cutlass bearing on the port side in front and starboard at the back makes me concerned. Thoughts?






I've got new trans fluid, Rotella T4 15-40 and a Motorcraft filter ready to go. Package from SKIDIM arriving today with two new pitot tubes, a tube of 5200, and the fuel tank sender arrives today. Still need to pick up a fiberglass repair kit for the muffler and a spare tire.
Reply With Quote
  #23  
Old 05-24-2018, 03:55 PM
PeterAK PeterAK is offline
TT Newbie
 
Join Date: Jun 2017
Boat: 1992 Prostar 190
Location: Wisconsin
Posts: 26
Another thing--the strainer only has two screws holding it on--there are four holes in it. Is looks like there are no empty holes in the hull though. Is that typical? The caulk around the strainer is also not in good shape. Since I have the tube of 5200 for the pitot tube replacement I'm tempted to pull off the strainer, clean up the hull, and reinstall it.
Reply With Quote
  #24  
Old 07-24-2018, 04:21 PM
PeterAK PeterAK is offline
TT Newbie
 
Join Date: Jun 2017
Boat: 1992 Prostar 190
Location: Wisconsin
Posts: 26
Updates!

UPDATE! I've been chipping away at my to do list on the ProStar. Happy with the progress, but still more to do! I've really enjoyed it so far. (Bought with 741 hours, rolled over 750 hours with this past weekend)

New fuel sender went in to fix the inop gas guage. New and old:


Pulled the muffler, ground out around the leaks which were all where the tubes met the body, and then glassed over the joints. Once cured, I painted it with engine paint. Finally, a few layers of plumbers tape on the threads of the drain plug. Looks great and no more leaks!


Help is important...


Ready for paint.


Back in. Here you can also see the new bilge vent hose.


New pitot tubes. These replacements from SkiDim have three holes vs the two of the OEM ones. I drilled out the bottom two holes to match up to the holes in the boat, and had to cut the top mounting hole off of the new pieces to fit under where the hose comes out of the boat. Mounted with 3M 4200 and two screws.


The hoses were original and showing cracks, so I replaced them all. I used a miter saw with a metal cutting blade to cut them to size. Makes a cloud of awful smoke, but makes a decent cut of the hose and wire embedded within. If you use this cutting method, make sure to wear a mask! Don't want to breathe that smoke...
Naked!

New hoses installed. Bought from SkiDim by the foot, and cut to size. The pre-formed hose needed to be trimmed, as SkiDim advised, to fit.


New trans fluid. Old stuff smelled fine. It was dirty, but not terrible.


New wheels and tires were a must. Old tires had a manufactured date of 2001, and when we head to the cabin its a 250 mile round trip. Thanks to @ThatsMrMastercraft for the help with wheels and tires. This pic also shows what a wash and wax can do. I used Meguiar's Gold Class Car Wash Shampoo & Conditioner, and Meguiar's Synthetic X-Press Spray Wax. Not much work, but made it look like a new boat. Also treated the vinyl with 303.


Stuff I didn't take pictures of:
-Greased the trailer bearings
-Replaced the shaft packing with GFO
-New impeller
-Oil change with Rotella 15-40
-Tightened pylon--it was loose!
-Greased rudder and steering
-New MasterCraft decals on the side--probably going to redo them. I'd like a slightly grey color, and want all of the side and back decals to match.


Still on my To Do List:
-Replace alternator belt (should have done this when I did the hoses)
-Shampoo carpet
-Replace wheel bearings -- they didn't get hot on the highway, but age and history is unknown. Better safe than sorry.
-Replace cutlass bearing
-Restore teak platform
-Ski, ski, ski!
Reply With Quote
  #25  
Old 07-24-2018, 04:25 PM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is offline
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 17,507
Looking great and love the helper!!

Thanks again for your business. I really appreciate it.
__________________
CUSTOM WHEEL & TIRE PACKAGES

$125 LED TRAILER LIGHT PACKAGE - FREE SHIPPING
REBUILDING HOLLEY MARINE CARBS - $325 DELIVERED
REBUILT COMPLETE MARINE HOLLEY 4160 CARBS $495 DELIVERED
Email - [email protected]
Reply With Quote
  #26  
Old 07-24-2018, 04:42 PM
curver900 curver900 is offline
MC Devotee
 
Join Date: Aug 2013
Boat: Mastercraft, prostar 2001 205v
Location: midwest
Posts: 2,395
where about are you in WI?

take a picture of the strut from straight on from the back.. make sure it is not bent...usually that is what makes that happen...

looks good!

If there is nothing wrong with the bearings I would just plan on repacking every 2 years and leave it at that...
Reply With Quote
  #27  
Old 07-24-2018, 04:42 PM
Timr71 Timr71 is offline
TT Enthusiast
 
Join Date: May 2016
Boat: 93 Ski Centurion Falcon
Location: Southeast
Posts: 341
Very nice!
Reply With Quote
  #28  
Old 07-24-2018, 05:10 PM
PeterAK PeterAK is offline
TT Newbie
 
Join Date: Jun 2017
Boat: 1992 Prostar 190
Location: Wisconsin
Posts: 26
Quote:
Originally Posted by curver900 View Post
where about are you in WI?

take a picture of the strut from straight on from the back.. make sure it is not bent...usually that is what makes that happen...

looks good!

If there is nothing wrong with the bearings I would just plan on repacking every 2 years and leave it at that...
I live on the west side of Milwaukee, and we have a cabin in Waupaca, on Spencer Lake.

I'll try to get a decent pic of the strut from behind. Thanks!
Reply With Quote
  #29  
Old 08-23-2018, 04:41 PM
PeterAK PeterAK is offline
TT Newbie
 
Join Date: Jun 2017
Boat: 1992 Prostar 190
Location: Wisconsin
Posts: 26
More progress!

After spending more time eyeballing the strut, I realized that the strut on the boat was in fact bent. I removed the old strut, which was a pretty easy process. I did not pull the drive shaft, just removed the bolts on the coupler and let it be free. With a bit of heat and hand pressure the strut came right off. The remaining caulk / sealant on the hull came off with Goof Off Pro and a plastic scraper. I dry fit the new strut (purchased from MCPartsDepot.com) and the drive shaft was almost perfectly centered in the shaft log, so I went ahead and installed it, using 3m 4200. The new strut comes with a new bushing already installed. The process of aligning the drive is an art, not a science... Adjust, measure. Adjust, measure. Tighten motor mounts, remeasure, curse, repeat process. My last time through it was getting late and was around .006 after tightening down so I called it good. Going to revisit this again to see if I to get it to .003 or better.



Still had the vibration, so the next step is the prop. I considered just having the old prop rebuilt, but the idea of getting a modern four blade CNC machined prop was too enticing. I went with an OJ 454, purchased direct from OJ and they are going to rebuild the old prop, after which it will be a spare.



Last night the boat was smooth as can be for the first time since I've owned it. I wouldn't say the prop made it a new boat, but it did improve the hole shot and add about 2 mph to the top end. I also think it made the wake where I ski at 15' off a bit smoother. I also got my six year old son up on skis behind the boat for the first time, which was fantastic! He has also been practicing his boat driving.



I have boiled linseed oil and mineral spirits on the shelf in the garage for when I have time to tackle refinishing the platform.

Good stuff, loving the boat!
Reply With Quote
  #30  
Old 08-23-2018, 05:05 PM
zsqure's Avatar
zsqure zsqure is offline
MC Devotee
 
Join Date: Jun 2012
Boat: MasterCraft X-14, '09 Blue
Location: Down the road from Double D
Posts: 1,175
I thought those 351's were supposed to run that valvoline oil with some additive for the flat tappet cam. Did something change along the way?
Attached Images
 
__________________
https://badges.fuelly.com/images/smallsig-us/302328.png
1988 prostar 190 SOLD
2001 Prostar 209 SOLD
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:13 PM.


2018