Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 07-11-2018, 06:07 PM
Waterbucket1 Waterbucket1 is offline
TT Newbie
 
Join Date: Jan 2018
Boat: 2015 X23
Location: Southeast
Posts: 24
X23 wont start

Started to get the boat out this afternoon and just as I pushed it out of the dock I realized that it would not start. Jiggled the throttle a little and it fired up. Wanted to be safe so I shut it down to see if it was just a fluke and no joy. Could not get it to start again. Played with it about 10 min and had it try to start one time in that period.

I fell pretty sure that it's the sensor on the backside of the throttle.

Anyone have any other ideas or the part number?

Thanks
Chuck

Sent from my SM-G965U using Tapatalk
Reply With Quote
  #2  
Old 07-12-2018, 08:22 AM
MattsCraft's Avatar
MattsCraft MattsCraft is offline
MC Devotee
 
Join Date: May 2008
Boat: 2013 X25 - 6.2 Ilmor Baby
Location: Cincinnati, OH
Posts: 1,781
For sure sounds like the throttle position sensor - Mine every once in a while will stick (Not sense Neutral position) But the jiggle works!

Try spraying down in & around the base with some electronics cleaner, might help.

Sorry, don't know the part number, but your should for sure!
Reply With Quote
  #3  
Old 07-12-2018, 01:45 PM
Waterbucket1 Waterbucket1 is offline
TT Newbie
 
Join Date: Jan 2018
Boat: 2015 X23
Location: Southeast
Posts: 24
Swich picture

Here is a picture of the switch that I suspect. Anyone know what it is called?

It operates by way of a magnet on the backside of the throttle, behind the side panel at the driver's seat.

Thanks
Chuck
Attached Images
  
Reply With Quote
  #4  
Old 07-12-2018, 02:14 PM
Maristar210's Avatar
Maristar210 Maristar210 is offline
MC Master Poster
 
Join Date: Apr 2005
Boat: paddle
Location: Midwest
Posts: 10,476
What you have is a throttle position sensor that is $20 and it disabled a $120,000 boat. Good job Mastercraft
Reply With Quote
  #5  
Old 07-14-2018, 08:14 AM
Waterbucket1 Waterbucket1 is offline
TT Newbie
 
Join Date: Jan 2018
Boat: 2015 X23
Location: Southeast
Posts: 24
Fixed...

Ended up being a $3.00 starter relay on top of the engine. It was just intermitting enough that I thought I was doing some good by jiggling the throttle. When in fact it was just the relay breaking down.

Well I learned a lot about neutral position switch, dash switch and throttle sensor.

Thanks for those who chimed in.

Chuck
Reply With Quote
  #6  
Old 07-15-2018, 08:07 AM
MattsCraft's Avatar
MattsCraft MattsCraft is offline
MC Devotee
 
Join Date: May 2008
Boat: 2013 X25 - 6.2 Ilmor Baby
Location: Cincinnati, OH
Posts: 1,781
Glad it was an easy/cheap fix!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:58 PM.


2018