Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Underwater Running Gear

Reply
 
Thread Tools Display Modes
  #1  
Old 06-11-2018, 12:12 PM
kmw105 kmw105 is offline
TT Newbie
 
Join Date: Oct 2016
Boat: Mastercraft, X25, 2014, 5.7
Location: South
Posts: 6
Gen 2 tab actuator problems

Has anyone had problems with their surf tab actuators failing? I have a 2014 X25 with 200 hours, this weekend my starboard (most used) tab failed to retract, upon inspection the actuator motor was making a rattling sound and not moving the tab unless I pushed.
I would appreciate any information and advice. To me it sounds like a worn out actuator, is replacement a big deal? thank you in advance.
Reply With Quote
  #2  
Old 06-12-2018, 10:27 AM
MattsCraft's Avatar
MattsCraft MattsCraft is online now
MC Devotee
 
Join Date: May 2008
Boat: 2013 X25 - 6.2 Ilmor Baby
Location: Cincinnati, OH
Posts: 1,784
Common problem - The seal goes out, water intrusion, rust and breaks off the plunger.

Replacement is pretty easy, just remove the top screws from the old & new one, replace with the new seal & new actuator. You do not need to re-wire.
Reply With Quote
  #3  
Old 06-13-2018, 11:30 AM
kmw105 kmw105 is offline
TT Newbie
 
Join Date: Oct 2016
Boat: Mastercraft, X25, 2014, 5.7
Location: South
Posts: 6
Thank you Matt!
Reply With Quote
Reply

Tags
actuator problem, gen 2 surf system

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:00 AM.


2018