Go Back   TeamTalk > General MasterCraft Topics > Tow Vehicles

Reply
 
Thread Tools Display Modes
  #1  
Old 06-04-2018, 10:59 AM
willyt's Avatar
willyt willyt is offline
MC Maniac
 
Join Date: May 2009
Boat: ER xstar
Location: high in the middle and round on both ends
Posts: 2,745
Caliper hanging

2007 Chevy Tahoe Ltz.

My front passengerís side caliper is hanging up - Iím getting way more brake dust on that side and the rotor is always very hot when I arrive someplace.

Simple fix, right? Unfortunately not. All my bleeder screws are frozen on the calipers (even the rears). So, in order to properly bleed the system, Iím thinking I need 4 new calipers, is that correct (not just the 2front ones)?

While Iím at it... rotors/pads too... so itís going to be a pricey endeavor?
Reply With Quote
  #2  
Old 06-04-2018, 12:04 PM
CantRepeat's Avatar
CantRepeat CantRepeat is offline
 
Join Date: Jul 2008
Boat: Passively looking for a CSX 265
Location: Roll Tide!!
Posts: 14,649
It could be a partially frozen or stuck proportioning valve. Although, that seems unlikely for just an 11 year old truck.

For the bleeder valves did your try some BP blaster on them for a couple of days.
__________________
Tim

"Heavy" beer is for wine drinkers that are too embarrassed to drink wine in front of their buddies. "Light" beer is a drinkin' man's beer!
Reply With Quote
  #3  
Old 06-04-2018, 12:15 PM
clrussell's Avatar
clrussell clrussell is offline
MC Addict
 
Join Date: Jul 2012
Boat: 40th Anniversary X Star!
Location: midwest
Posts: 5,946
You actually only have to bleed the caliper you change. As long as the master Cyl doesn’t loose all the fluid.

Change the hose too while your there.

You could also just have a caliper slide stuck or a brake pad stuck on its slides, I see this more than calipers
Reply With Quote
  #4  
Old 06-04-2018, 12:41 PM
fstaslp fstaslp is offline
TT Enthusiast
 
Join Date: Aug 2010
Boat: 1999 Mastercraft Maristar 230VRS
Location: Indianapolis, IN
Posts: 494
I would check to make sure the slides are greased. I recently found where one of mine weren't and it fixed the issue.
__________________
1999 Maristar 230 VRS
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:52 PM.


2018