Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 06-09-2013, 06:42 PM
CoconutGilligan CoconutGilligan is offline
TT Newbie
 
Join Date: Jun 2013
Boat: MasterCraft, ProStar 190, 1997
Location: Southeast
Posts: 8
Raw Water Pump 1997 ProStar 190

I'm trying to find a new Raw Water Pump for my 1997 ProStar 190.

I'm about 80% sure I have a LT-1 motor but I'm not sure how to confirm that.

Anyone know of a good place to buy one of these? I'm having trouble locating a part number. Any input would be greatly appreciated.

These are the only place I've found so far. I'm nervous that I'm going to end up with a rebuilt one.

http://www.wakeboards.com/Raw-water-...p_lt-1_ltr.htm

http://www.waterskis.com/685020-p/ra...p_lt-1_ltr.htm

Thank You.
Attached Images
  

Last edited by CoconutGilligan; 06-09-2013 at 06:45 PM. Reason: Attach Picture
Reply With Quote
  #2  
Old 06-09-2013, 07:12 PM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 2,364
I'm 81% sure you don't have the LT-1. The difference between the LT-1 pump and the TBI pump is the mount/pulley. The LT-1 pump has three holes, the TBI pump has several (6?) holes. It looks like your pump has 6 holes.

http://www.skidim.com/prodinfo.asp?number=RA057023

If you have an LT-1, your spark arrestor will be on the front of the engine and you should have plastic injector/fuel rail covers that say "Corvette".

__________________
'96 ProStar 205 SD LT-1
Reply With Quote
  #3  
Old 06-09-2013, 07:45 PM
CoconutGilligan CoconutGilligan is offline
TT Newbie
 
Join Date: Jun 2013
Boat: MasterCraft, ProStar 190, 1997
Location: Southeast
Posts: 8
Pictures of Engine

Yes, it does have 6 holes. Here are some pictures of the engine. Vortec 350? It appears that the person who sold me the boat has misinformed me. Thank You.
Attached Images
  

Last edited by CoconutGilligan; 06-09-2013 at 07:56 PM. Reason: Pictures
Reply With Quote
  #4  
Old 06-09-2013, 08:12 PM
CantRepeat's Avatar
CantRepeat CantRepeat is offline
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 14,449
Not an LT1 and I'm 100% sure of that.
__________________
Tim

"Heavy" beer is for wine drinkers that are too embarrassed to drink wine in front of their buddies. "Light" beer is a drinkin' man's beer!
Reply With Quote
  #5  
Old 06-09-2013, 08:13 PM
Engine Nut's Avatar
Engine Nut Engine Nut is offline
TT Enthusiast
 
Join Date: Apr 2005
Location: TN
Posts: 317
If that is the pump that came off your engine, you do not have an LT1. The mounting flange that attaches to the engine on an LT1 or LTR only has three mounting holes. All the other engines use a flange with six holes although only three are used. The Indmar P/N is 685001-1. You can get one from inboardonline.com
__________________
Engine Nut
Indmar Marine Engines
Power to the Sport
Reply With Quote
  #6  
Old 06-09-2013, 08:16 PM
CoconutGilligan CoconutGilligan is offline
TT Newbie
 
Join Date: Jun 2013
Boat: MasterCraft, ProStar 190, 1997
Location: Southeast
Posts: 8
Sweet, thank you so much.
Reply With Quote
  #7  
Old 06-09-2013, 09:09 PM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 2,364
Don't feel bad about having the TBI, it's still a great engine and will do everything you want it to do.

Welcome to TeamTalk, a great resource for all your MasterCraft questions. Sooner or later we all have something to figure out on our boats, and the answers are fairly easy to come by on here.

Now let's see some pics of that boat!
Reply With Quote
  #8  
Old 06-09-2013, 10:21 PM
CoconutGilligan CoconutGilligan is offline
TT Newbie
 
Join Date: Jun 2013
Boat: MasterCraft, ProStar 190, 1997
Location: Southeast
Posts: 8
I have a list of things to do to the boat.

I've already had to put in a new knock sensor. And put in a new radio.

The bow light needs to be replaced, simple enough.

My fuel gauge always says full, so the float is possibly stuck. I have to fill it up every time I take it out.

One of the speedometers is broken. Water was pouring out of it so I had to put a golf tee in the tube that connects to it, until I can locate a new one. I'm pretty sure the company that made my factory ones is now out of business so I'll probably just buy two new ones.

And I'm not sure what it's called? Transmission cooler? It's before the raw water makes it to the raw water pump, there's a filter/strainer in it that I occasionally find pine needles in. One of the ports is pinched from over tightening the exit hose and probably reducing water flow.

It's depressing that there's this many things broken, but nothing serious. One thing at a time, and the leaking raw water pump is numero uno. So glad I found Team Talk.
Attached Images
 
Reply With Quote
  #9  
Old 06-09-2013, 11:21 PM
Table Rocker's Avatar
Table Rocker Table Rocker is offline
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 2,364
Looks great to me. I like that burgundy color too.
__________________
'96 ProStar 205 SD LT-1
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:22 PM.