Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 06-10-2012, 10:23 PM
srelMCX-10 srelMCX-10 is offline
TT Newbie
 
Join Date: Jun 2011
Boat: Mastercraft X-10 2005 350MCX
Location: Midwest
Posts: 11
Check Engine Alarm

Had some trouble with my 2005 X10 this weekend. The engine would warm up fine and oil pressure and water temp seemed okay. We took a few hot laps around lake and when when I brought throttle back down to lower speed or no wake speed the oil pressure would fall and I would get a check engine alarm. I shut boat off and restarted and alarm was gone. I got boat back to dock and let it idle for 15 minutes or so and nothing happened. It seems like it only happens when coming down from higher speeds. I had impellar changed last fall and water temp stays at 160 or below so I don't think it is that. I checked the oil and it is at the last hole on the dipstick before the add range but still in operation range. Is that to low? I would have added some oil, but it is hard to find on a Sunday in rural Wisconsin. Can you get a check engine light if the oil is too low, or I am looking in wrong direction? Is there something else I should be looking at?
__________________

srelMCX-10
Reply With Quote
  #2  
Old 06-11-2012, 10:46 AM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
 
Join Date: Jun 2007
Boat: 2002 X Star
Location: Lake Tuscaloosa, AL
Posts: 2,338
Anything else happen when the alarm sounded; did the stereo go off or anything like that?
__________________
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote
  #3  
Old 06-11-2012, 05:24 PM
srelMCX-10 srelMCX-10 is offline
TT Newbie
 
Join Date: Jun 2011
Boat: Mastercraft X-10 2005 350MCX
Location: Midwest
Posts: 11
No, I don't believe so. I just got the warning beep and check engine on my display. When I tried to advance the throttle nothing would happen unlike when I had an impeller problem and I could advance the throttle, but only to a certain RPM's.
__________________

srelMCX-10
Reply With Quote
  #4  
Old 06-12-2012, 10:01 AM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
 
Join Date: Jun 2007
Boat: 2002 X Star
Location: Lake Tuscaloosa, AL
Posts: 2,338
Sorry, I don't really know then.

Hopefully Jimn or EngineNut will run across your thread.
__________________
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote
  #5  
Old 06-17-2012, 10:39 PM
gstringlover gstringlover is offline
TT Newbie
 
Join Date: May 2008
Boat: 05 xstar 8.1 swap
Location: midwest
Posts: 19
hey bud if u get the boat scanned ,,,, tell ur tech to look for a tell tale those are history faults,,, how many hours on the boat anyways
Reply With Quote
  #6  
Old 06-18-2012, 12:38 AM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 17,312
Send a message via Skype™ to mikeg205
Quote:
Originally Posted by srelMCX-10 View Post
Had some trouble with my 2005 X10 this weekend. The engine would warm up fine and oil pressure and water temp seemed okay. We took a few hot laps around lake and when when I brought throttle back down to lower speed or no wake speed the oil pressure would fall and I would get a check engine alarm. I shut boat off and restarted and alarm was gone. I got boat back to dock and let it idle for 15 minutes or so and nothing happened. It seems like it only happens when coming down from higher speeds. I had impellar changed last fall and water temp stays at 160 or below so I don't think it is that. I checked the oil and it is at the last hole on the dipstick before the add range but still in operation range. Is that to low? I would have added some oil, but it is hard to find on a Sunday in rural Wisconsin. Can you get a check engine light if the oil is too low, or I am looking in wrong direction? Is there somethinlpug else I should be looking at?
I would say oil is a bit low...I always carry a spare quart of oil and a quart of tranny fluid... here's a helpful link Things to Bring in Boat

Did you notice oil pressure drop at all?
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #7  
Old 06-18-2012, 05:51 PM
srelMCX-10 srelMCX-10 is offline
TT Newbie
 
Join Date: Jun 2011
Boat: Mastercraft X-10 2005 350MCX
Location: Midwest
Posts: 11
Boat has 217 hours. Yes the oil pressure did drop when coming down from cruising speed to idol or no wake speed. I added some oil this weekend and I did not have any alarms. Oil pressure did drop when coming down from higher speeds to idle or no wake speeds but not as drastically. I am still debating if I should take it in to get a computer on it.
__________________

srelMCX-10
Reply With Quote
  #8  
Old 06-18-2012, 07:07 PM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
 
Join Date: Jun 2007
Boat: 2002 X Star
Location: Lake Tuscaloosa, AL
Posts: 2,338
What engine do you have an what did the pressure drop to? Post and someone will let you know how the pressure compares to their ride.
__________________
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote
  #9  
Old 06-18-2012, 11:32 PM
srelMCX-10 srelMCX-10 is offline
TT Newbie
 
Join Date: Jun 2011
Boat: Mastercraft X-10 2005 350MCX
Location: Midwest
Posts: 11
It has the 350 MCX and it dropped down to between 10 and 20 and seemed to stay there and not recover. Thanks for the help!
__________________

srelMCX-10
Reply With Quote
  #10  
Old 06-19-2012, 10:05 AM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
 
Join Date: Jun 2007
Boat: 2002 X Star
Location: Lake Tuscaloosa, AL
Posts: 2,338
I think you will find that 10 - 20 is pretty normal at idle.
__________________
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:30 AM.