Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Audio/Stereo

Reply
 
Thread Tools Display Modes
  #1  
Old 03-14-2018, 11:47 PM
Waterbucket1 Waterbucket1 is offline
TT Newbie
 
Join Date: Jan 2018
Boat: 2015 X23
Location: Southeast
Posts: 29
Touchscreen Radio Controls

I just upgraded my X23 to a touchscreen. Ordered the kit and installed myself, very easy for those interested, just a bit hard on the wallet.

Everything comes up and works great with one exception. When I punch the Audio button, everything comes up and works, except the few buttons in the middle of the screen. In BT mode it's the play/pause button, and search forward and back buttons. Everything else works: volume, equalizer, source, etc. Any ideas on why these buttons wont work? Prior to this touchscreen upgrade I just upgrade to the Fusion 755 stereo, and all communication to the fusion remote is working properly.

I live about 2 hours away from a MC dealer, that's why I try to do most things myself. Any help would be greatly appreciated.

Thanks
Chuck
Reply With Quote
  #2  
Old 03-15-2018, 08:27 AM
dt37803's Avatar
dt37803 dt37803 is offline
MC Devotee
 
Join Date: Sep 2013
Boat: 2014 X2 5.7 Pro Surf Gen 2
Location: Lake Tellico home of MC
Posts: 1,033
Great project. Sorry I can't help but how hard on the wallet was it?
Reply With Quote
  #3  
Old 03-15-2018, 10:49 AM
Waterbucket1 Waterbucket1 is offline
TT Newbie
 
Join Date: Jan 2018
Boat: 2015 X23
Location: Southeast
Posts: 29
$5,465.07 to be exact, install took about 30 min.

Also would like to get the GPS module if anyone on TT has one for sale PM me.

Thanks
Chuck
Reply With Quote
  #4  
Old 09-19-2018, 11:06 AM
mastercraftka's Avatar
mastercraftka mastercraftka is offline
TT Enthusiast
 
Join Date: Jul 2017
Boat: 2017 XT23 just traded the 2004 XSTAR, first was a prostar 190
Location: Hondo, Texas
Posts: 410
Quote:
Originally Posted by Waterbucket1 View Post
I just upgraded my X23 to a touchscreen. Ordered the kit and installed myself, very easy for those interested, just a bit hard on the wallet.

Everything comes up and works great with one exception. When I punch the Audio button, everything comes up and works, except the few buttons in the middle of the screen. In BT mode it's the play/pause button, and search forward and back buttons. Everything else works: volume, equalizer, source, etc. Any ideas on why these buttons wont work? Prior to this touchscreen upgrade I just upgrade to the Fusion 755 stereo, and all communication to the fusion remote is working properly.

I live about 2 hours away from a MC dealer, that's why I try to do most things myself. Any help would be greatly appreciated.

Thanks
Chuck
So you had originally the small screen and the buttons on each side? Do you have regular guages in front on the dash?

$5,400 bucks to upgrade really???
__________________
2017 XT23
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:06 AM.


2018