Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #1  
Old 05-20-2018, 05:28 PM
LKNtristar's Avatar
LKNtristar LKNtristar is offline
TT Enthusiast
 
Join Date: Jul 2014
Boat: 1998 Mastercraft Maristar 200VRS
Location: Southeast
Posts: 246
Randomly Filling ... Advice

After surfing all day and then sitting out in a cove, on the way back in to the marina my ballast randomly started filling. Once I shut them off and manually drained, they came back on again ... and again... and again. It was almost as if I had a rider profile engaged and it was trying to get the ballast levels full to the profile. Then It would drain to 1 percent, then fill to 5% and keep doing that. I was nervous the pumps would get over worked on my way in and die. Anyone experienced the pumps randomly coming on (all of them at once) and randomly drain right after. Was just a strange 10min of tinkering around trying to find the cause ...


Sent from my iPhone using Tapatalk

Last edited by LKNtristar; 05-20-2018 at 05:52 PM.
Reply With Quote
  #2  
Old 05-21-2018, 03:53 PM
MiyaX2 MiyaX2 is offline
TT Newbie
 
Join Date: May 2018
Boat: Mastercraft, X2, 2010, Indmar MCX 350
Location: West
Posts: 1
I have this same type of random filling question? I was out yesterday and my center ballast tank would keep refilling it's self, but would not drain right after. It even seemed to do this with the key in the aux position. I tried to reset all rider profiles to see if that helped without any luck. I'm still learning how to use the perfect pass setting though.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:25 AM.


2018