Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #11  
Old 09-01-2016, 09:07 AM
BrianS's Avatar
BrianS BrianS is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: '08 X14
Location: Dayton, OH
Posts: 428
If the VDIG isn't working it's not the MMDC, it has nothing to do with the VDIG. Do your gauges even cycle when you turn the key. On first power up the gauges should cycle the full range of motion, then start reading. If that is not happening you have a power issue. There are breakers on a panel under the dash (the little push button things), but there are also fuses in-line in the various wiring under the dash (yes, that is annoying). I'd start looking for a blown fuse or maybe a connector in a wiring harness came loose.
Reply With Quote
  #12  
Old 09-01-2016, 09:18 AM
Bruce-ActionWater's Avatar
Bruce-ActionWater Bruce-ActionWater is offline
TT Enthusiast
 
Join Date: Feb 2014
Boat: 1994 ProStar 190 LT-1 Slot
Location: Midwest
Posts: 301
Quote:
Originally Posted by Mastar View Post
So I just bought a 2009 x star and I have an issue. I knew the vdig didn't work properly when I bought it, the up button didn't work. So I bought a new one from Great Lakes skipper and replaced it. Turn battery and key on and nothing. No flash or anything. Like it isn't getting power also my volt meter is not working any longer. Also when I plug the old one in it no longer works at all either.
I should mention the vdigs appear the same other than the new one doesn't have a video input. Can someone help me out here ! I really hope it's something simple.
Did you buy the right model VDIG? There are specific VDIGs for different years and engine set ups. Check the Medallion number on both and make sure they match
__________________
Bruce Jesionowski - Parts & Warranty
Store: 810.629.1342
Action Water Sports-Fenton
8051 Old US 23
Fenton, MI 48430
www.actionwater.com

BRINGING FAMILIES TOGETHER


1984 MasterCraft Stars&Stripes. Fully restored-SOLD
1994 MasterCraft PS190 LT-1 Slot
Reply With Quote
  #13  
Old 09-01-2016, 01:39 PM
osmonet's Avatar
osmonet osmonet is offline
TT Regular
 
Join Date: Mar 2015
Boat: 2008 X2, MCX
Location: Twin Cities
Posts: 911
There are some twin engine versions they will say "dual" on the serial number sticker. Also on that sticker will be a version / revision. According to medallion, as long as the new one has a later version they should be backward compatible.

I had a similar power up issue in mine but I was able to solve it by disconnecting the battery and then powering back up


Sent from my iPhone using Tapatalk
Reply With Quote
  #14  
Old 09-01-2016, 02:12 PM
Mastar Mastar is offline
TT Enthusiast
 
Join Date: Aug 2016
Boat: 2009 Mastercraft X Star
Location: Midwest
Posts: 172
The gauges don't do a thing on my dash. Won't budge. There is power to the MMDC so shouldn't I expect something to come out of it. There is no voltage at the gauges. There is nothing tripped on the panel, I checked a couple inline fuses under there, but will look again tomorrow when I get home.
Reply With Quote
  #15  
Old 09-01-2016, 02:29 PM
Bruce-ActionWater's Avatar
Bruce-ActionWater Bruce-ActionWater is offline
TT Enthusiast
 
Join Date: Feb 2014
Boat: 1994 ProStar 190 LT-1 Slot
Location: Midwest
Posts: 301
Quote:
Originally Posted by Mastar View Post
The gauges don't do a thing on my dash. Won't budge. There is power to the MMDC so shouldn't I expect something to come out of it. There is no voltage at the gauges. There is nothing tripped on the panel, I checked a couple inline fuses under there, but will look again tomorrow when I get home.
If you have zero volts at the gauges then there is a wiring issue between the MMDC and the gauges or the MMDC box is bad. You could also have a CAN date issues between the ECM and MMDC box
__________________
Bruce Jesionowski - Parts & Warranty
Store: 810.629.1342
Action Water Sports-Fenton
8051 Old US 23
Fenton, MI 48430
www.actionwater.com

BRINGING FAMILIES TOGETHER


1984 MasterCraft Stars&Stripes. Fully restored-SOLD
1994 MasterCraft PS190 LT-1 Slot
Reply With Quote
  #16  
Old 09-01-2016, 07:38 PM
Mastar Mastar is offline
TT Enthusiast
 
Join Date: Aug 2016
Boat: 2009 Mastercraft X Star
Location: Midwest
Posts: 172
It is a Vdig dual version 5 I believe. Talked to a rep at medallion and he said it shouldn't cause issues, but it may not have the same options. Plugged in the new Mmdc and still nothing FML. Is the CAN data cable just the bundle of wires that runs from the front of the engine? Does it travel under the floor to the helm?
Reply With Quote
  #17  
Old 09-02-2016, 08:57 AM
Bruce-ActionWater's Avatar
Bruce-ActionWater Bruce-ActionWater is offline
TT Enthusiast
 
Join Date: Feb 2014
Boat: 1994 ProStar 190 LT-1 Slot
Location: Midwest
Posts: 301
Quote:
Originally Posted by Mastar View Post
It is a Vdig dual version 5 I believe. Talked to a rep at medallion and he said it shouldn't cause issues, but it may not have the same options. Plugged in the new Mmdc and still nothing FML. Is the CAN data cable just the bundle of wires that runs from the front of the engine? Does it travel under the floor to the helm?
I would guess the harness runs up the STBD gunnel
__________________
Bruce Jesionowski - Parts & Warranty
Store: 810.629.1342
Action Water Sports-Fenton
8051 Old US 23
Fenton, MI 48430
www.actionwater.com

BRINGING FAMILIES TOGETHER


1984 MasterCraft Stars&Stripes. Fully restored-SOLD
1994 MasterCraft PS190 LT-1 Slot
Reply With Quote
  #18  
Old 09-04-2016, 10:05 PM
Mastar Mastar is offline
TT Enthusiast
 
Join Date: Aug 2016
Boat: 2009 Mastercraft X Star
Location: Midwest
Posts: 172
Finally found a blown fuse up under the helm. Anyone need a mmdc pm me. Now I need a new starter. Had to get towed by my old malibu today!
Reply With Quote
  #19  
Old 09-08-2016, 09:04 PM
osmonet's Avatar
osmonet osmonet is offline
TT Regular
 
Join Date: Mar 2015
Boat: 2008 X2, MCX
Location: Twin Cities
Posts: 911
Glad you found the fuse. Good to know


Sent from my iPhone using Tapatalk
Reply With Quote
  #20  
Old 11-15-2016, 08:44 AM
traveler08 traveler08 is offline
TT Newbie
 
Join Date: Oct 2014
Boat: 2008 X-15
Location: Southeast
Posts: 2
Quote:
Originally Posted by osmonet View Post
Glad you found the fuse. Good to know


Sent from my iPhone using Tapatalk
I am new to TT and have been following this vdig thread intently. I have '08 X-15 and my scroll down button has stopped working. Called dealer (150 miles away) and they want to replace vdig for approximately $3000, if I can get the boat to them which I can't. Have looked at vdig and found some corrosion on push button pad and since the vdig works properly, think push button pad is issue. Some members refer to getting replacement pad from Medallion? Anyone know who to call and speak with?

Last edited by traveler08; 11-15-2016 at 10:16 AM. Reason: Spelling
Reply With Quote
Reply

Tags
gauge, vdig

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:29 PM.


2018