Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Audio/Stereo

Reply
 
Thread Tools Display Modes
  #1  
Old 05-11-2015, 09:54 PM
Turndown4? Turndown4? is offline
TT Newbie
 
Join Date: Feb 2015
Boat: Mastercraft NXT 2015 5.7
Location: Midwest
Posts: 5
New here/ Sound system question.

New to boating and forum. Picked up a 2015 NXT and decided to add tower speakers.

Bought Roswell Focal spin speakers with Roswell amp, amp kit and tower kit. I have power to amp. And I tested the speakers and know they work. Right now there is nothing when I hook the speakers to the amp. I have the out put from the head unit hooked to input on the amp with RCA cables. What could I be doing wrong? Is there a setting on the radio I need to switch on? Could the amp be bad?

I'm not a pro when wiring devices but this does not seem difficult to figure out. Any help would be greatly appreciated.

Thank you -Brad
Reply With Quote
  #2  
Old 05-11-2015, 10:14 PM
Cain0725 Cain0725 is offline
MC Fanatic
 
Join Date: Feb 2014
Boat: 2006. Mastercraft maristar
Location: South central
Posts: 683
could be a number of things,, take a test light ,, you can buy one at any parts store for 10 bucks,, and make sure everything is getting power. If it is, next i would check the amp gaines,, make sure it is not all the way down. Also why your there make sure all your rca's are hooked up,, sometimes they come loose. Last make sure your speakers are hooked up. I am assuming the first thing you did was make sure you were on the right setting,, radio, cd, aux for iPhone or iPod ect.
Reply With Quote
  #3  
Old 05-11-2015, 10:27 PM
paintpollz's Avatar
paintpollz paintpollz is offline
MC Devotee
 
Join Date: Oct 2014
Boat: 2002 Prostar 197
Location: Fort Worth
Posts: 1,481
Switch RCA cables from another amp. If it works, then it's a radio setting , which is what I think it is.
__________________
Kevin
Reply With Quote
  #4  
Old 05-11-2015, 10:44 PM
Turndown4? Turndown4? is offline
TT Newbie
 
Join Date: Feb 2015
Boat: Mastercraft NXT 2015 5.7
Location: Midwest
Posts: 5
Radio setting seems most logical.
Reply With Quote
  #5  
Old 05-15-2015, 12:43 PM
MEMMER99's Avatar
MEMMER99 MEMMER99 is offline
TT Regular
 
Join Date: Jun 2014
Boat: 2002 Mastercraft X30 Cadillac LQ-9
Location: Milpitas, CA
Posts: 52
Check your remote wire connection from the head unit to the amp. You should get a green light on the amp if it is working correctly.
Reply With Quote
  #6  
Old 05-15-2015, 10:21 PM
Turndown4? Turndown4? is offline
TT Newbie
 
Join Date: Feb 2015
Boat: Mastercraft NXT 2015 5.7
Location: Midwest
Posts: 5
Name:  20150515_202644.jpg
Views: 264
Size:  44.7 KB

This is the head unit on the NXT. If I use my phone jack with RCA cables into the amp the system works. When I plug amp into output of attached radio picture the nothing.

I will check remote wire next.
Reply With Quote
  #7  
Old 05-15-2015, 10:35 PM
MLA MLA is online now
MC Devotee
 
Join Date: May 2012
Boat: pontoon
Location: Lake Wylie Area
Posts: 1,437
Quote:
If I use my phone jack with RCA cables into the amp the system works.
Nothing wrong with remote turn-on then.

The fusion has zones, make sure the volume is turn up for the zone you are now using for the new amp
Reply With Quote
  #8  
Old 05-16-2015, 11:53 PM
lashburn1's Avatar
lashburn1 lashburn1 is offline
MC Maniac
 
Join Date: Aug 2013
Boat: 2015 X20 SS
Location: Oceanside California
Posts: 4,931
You Also need to turn the ZONE ON...VERY IMPORTANT !!! or you will Get NOTHING
Its in the settings, it is not on Auto MAtically
__________________

2015 X20 SS GEN2 6.0
2016 G21 Coastal
2014 X46 GEN2 7.4
2014 X30 GEN2 5.7
2006 VRS200 SS 5.7
2013 X30 GEN2 6.2
2013 Yamaha 242LS
Reply With Quote
  #9  
Old 05-17-2015, 05:07 PM
Turndown4? Turndown4? is offline
TT Newbie
 
Join Date: Feb 2015
Boat: Mastercraft NXT 2015 5.7
Location: Midwest
Posts: 5
Remote is on and good to go.

Fairly sure zone is on but will check that later this week.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:21 PM.


2018