Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 08-29-2015, 01:58 PM
TLR67's Avatar
TLR67 TLR67 is offline
MC Fanatic
 
Join Date: Jul 2010
Boat: 1990 190
Location: Southeast
Posts: 573
1990 Velvet Drive Moving in Neutral

Just noticed today a knock... knock... knock... looked down and noticed my coupler (Whole drive shaft) was moving 1/4 inch every other second while in Neutral... It would knock in gear and reverse too.. Didn't want to take it out but want to pick the experts minds here on what it could be? I have changed the tranny fluid with the 2 Quarts of Dex on a regular basis and have never had any slippage issues ect.. Could it be the DAMPER plate or springs in the tranny? It has about 1065 Hours on it.... After a carb rebuild last week again this is the last thing I neededAlso do you need to yank your engine to do this or can you just remove the drive shaft.. disconnect then take out tranny? ....Any help would be appreciated...

Last edited by TLR67; 08-29-2015 at 02:12 PM.
Reply With Quote
  #2  
Old 08-29-2015, 10:46 PM
1990lmtd's Avatar
1990lmtd 1990lmtd is offline
TT Enthusiast
 
Join Date: Jan 2010
Boat: 1990 Prostar 190 Limited 351 Power slot
Location: Northeast
Posts: 344
Send a message via Yahoo to 1990lmtd
Trans takes about 30 to 40 minutes to remove. I'm not sure what the issue could be. Could you post a video?
Reply With Quote
  #3  
Old 08-30-2015, 05:46 AM
TLR67's Avatar
TLR67 TLR67 is offline
MC Fanatic
 
Join Date: Jul 2010
Boat: 1990 190
Location: Southeast
Posts: 573
Boats already back in storage but I am pretty sure from other posts I have seen its the damper plate...thanks

Last edited by TLR67; 08-30-2015 at 06:31 PM.
Reply With Quote
  #4  
Old 09-05-2015, 08:24 PM
BrianM's Avatar
BrianM BrianM is offline
MC Addict
 
Join Date: Jul 2004
Boat: 1988 Prostar 190
Location: Mandeville, LA
Posts: 5,074
Same thing happened with my old '88. Damper plate was the fix.
__________________


1997 Prostar 190, TBI 350, 1:1, OJ XMP 13 x 11.5, Stargazer, Hot Shower, Heated Drivers Seat, Reuben/Mountain Rock/Nite Navy


Reply With Quote
  #5  
Old 09-14-2015, 10:08 AM
TLR67's Avatar
TLR67 TLR67 is offline
MC Fanatic
 
Join Date: Jul 2010
Boat: 1990 190
Location: Southeast
Posts: 573
Just a FYI New Damper plate installed but its still slipping..... Into the clutch we go.... Damn... I just put it all back together too... Might just wait for winter to do this...
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:31 AM.