Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 09-04-2018, 12:55 AM
ksulliv's Avatar
ksulliv ksulliv is offline
TT Regular
 
Join Date: Jul 2013
Boat: 83 S&S
Location: Oregon
Posts: 56
83 Fuel Pump Failures

Hi All, I have an 83 with the standard 351 and I keep going through fuel pumps. The original pump started pumping weak earlier this summer so I purchased a mechanical Carter M60389, popped it in, and ran great for probably 5 hrs and then is started pumping fuel back into the carburetor through the vent tube. I assumed I just got a faulty pump so I returned that one for a new one and again, after probably 5 or so hours, it started pumping fuel back in through the vent tube into the carburetor. I'm thinking there is no way I got two faulty pumps so what is going on here, what is causing this? Thanks in advance for the help!
Reply With Quote
  #2  
Old 09-04-2018, 02:27 PM
thatsmrmastercraft's Avatar
thatsmrmastercraft thatsmrmastercraft is offline
MC Master Poster
 
Join Date: Sep 2008
Boat: 1977 Stars & Stripes
Location: St. Paul, MN
Posts: 17,507
Interesting. I just installed the same pump in my boat but only have an hour on it. No problems yet.
__________________
CUSTOM WHEEL & TIRE PACKAGES

$125 LED TRAILER LIGHT PACKAGE - FREE SHIPPING
REBUILDING HOLLEY MARINE CARBS - $325 DELIVERED
REBUILT COMPLETE MARINE HOLLEY 4160 CARBS $495 DELIVERED
Email - tirespl[email protected]
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:49 PM.


2018