Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 08-06-2017, 10:45 PM
kyfooter's Avatar
kyfooter kyfooter is offline
MC Fanatic
 
Join Date: May 2007
Boat: 2013 197 WTT / 1992 Barefoot Sanger
Location: DFW
Posts: 575
2013 - steering cable bad already?

I have a 2013 WTT with 180 hours. Steering started to get stiff last week so I greased the rudder, and the steering cable in the back of the boat.

Skied today and it's still stiff. Before anyone asks, when I had the cable disconnected from the rudder, the rudder turned very easily.

So...is my cable bad already? Any issues with 2013 cables going bad prematurely? I would understand if it was 7-8 years old, but barely 4 years old with only 180 hours seems early.

Anything else I should try?

Thanks.
Reply With Quote
  #2  
Old 08-07-2017, 10:20 AM
swc5150's Avatar
swc5150 swc5150 is offline
TT Enthusiast
 
Join Date: Aug 2011
Boat: 2015 Prostar
Location: Midwest
Posts: 422
You could try to repack your rudder first, since it's a really easy and quick job. However, being your rudder turns easy when you disconnect the cable, that's more likely the culprit. A cable can easily go bad in 4 years unfortunately. I've seen them go bad even earlier.
Reply With Quote
  #3  
Old 08-07-2017, 12:09 PM
kyfooter's Avatar
kyfooter kyfooter is offline
MC Fanatic
 
Join Date: May 2007
Boat: 2013 197 WTT / 1992 Barefoot Sanger
Location: DFW
Posts: 575
I figured. Was holding out hope for a better option.

I did find a pretty funny YouTube video about a "guaranteed" way to loosen a stiff steering cable. The guy goes to great length to force oil into the cable, and works it for several hours, before concluding the "guaranteed" way to fix the issue is to buy a new one.
Reply With Quote
  #4  
Old 08-07-2017, 02:39 PM
JohnnyB's Avatar
JohnnyB JohnnyB is offline
MC Maniac
 
Join Date: Oct 2004
Boat: 2004 Prostar 190
Location: Titletown
Posts: 3,843
My steering cable was buttery smooth and died within a year. The culprit was a leak in my cover and the angle the boat sat at on the lift. Water would fill the back bilge and likely left the end of the cable submerged in bilge water occasionally. Once the water intrudes it corrodes and locks up in a hurry.

I now have a canopy on my lift and run the bilge pump religiously before lifting the boat out of the water.
__________________
Everyone Dies, but not everyone lives

2004 Prostar 197, ACME 843
Reply With Quote
  #5  
Old 08-07-2017, 02:44 PM
mzimme's Avatar
mzimme mzimme is offline
MC Addict
 
Join Date: Mar 2012
Boat: 2006 20' Vdrive
Location: Kansas City
Posts: 5,454
Still under warranty?
__________________
-Mike
Reply With Quote
  #6  
Old 08-07-2017, 03:20 PM
kyfooter's Avatar
kyfooter kyfooter is offline
MC Fanatic
 
Join Date: May 2007
Boat: 2013 197 WTT / 1992 Barefoot Sanger
Location: DFW
Posts: 575
I don't think it's under warranty. I believe 2013 was the last year of a 3 year warranty. In 2014 they went to 5 year.

Understood about the water in the bilge, but you can eat of my bilge...stays dry all the time.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:12 AM.


2018