Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 05-23-2018, 08:39 PM
Wheelin98TJ Wheelin98TJ is offline
TT Enthusiast
 
Join Date: Jul 2015
Boat: 2005 XStar
Location: Devils Lake
Posts: 159
Oil filter for 2005 LQ9 6.0

Anybody know what oil filter I am supposed to use on my 2005 XStar with the 6.0 LQ9?

I used a Napa Gold 1069 last year and it has a hole in the bottom of it from rubbing on a bolt.

Iím thinking I used too long of a filter?
Reply With Quote
  #2  
Old 05-23-2018, 08:53 PM
Wheelin98TJ Wheelin98TJ is offline
TT Enthusiast
 
Join Date: Jul 2015
Boat: 2005 XStar
Location: Devils Lake
Posts: 159
I probably should have put this in the Maintenance Forum. Sorry if this needs moved.
Reply With Quote
  #3  
Old 05-23-2018, 10:16 PM
mcmx2 mcmx2 is offline
TT Enthusiast
 
Join Date: Sep 2008
Boat: 2005 TT 197 #77
Location: Southeast
Posts: 184
I run the same filter as you on my 05 with an LQ9. I did have the bracket bolt wear a pinhole one time in the filter.
__________________
2005 197 TT #77 LQ9
Reply With Quote
  #4  
Old 05-24-2018, 09:16 AM
2RLAKE's Avatar
2RLAKE 2RLAKE is offline
MC Addict
 
Join Date: Jun 2007
Boat: '13 x10 with 6.0 and '93 25th Anniversary Limited Edition
Location: Cincinnati OH & Lake Norris TN
Posts: 5,280
I used Mobil M1-202 or K& N 2002 oil filters on mine
Reply With Quote
  #5  
Old 05-24-2018, 12:36 PM
ktmrider6's Avatar
ktmrider6 ktmrider6 is offline
TT Regular
 
Join Date: Apr 2013
Boat: 1992 pro 190, 1999 sportstar 190 OB, 2003 209 6.0L
Location: midwest
Posts: 37
Wheelin,
I can look tonight, My209 has the 6.0 but my filter is remote mounted up higher so you can service. I use the FRAM equiv to PF 25 filter AC filter. That's what my shop manual calls for.
shoot me your cell and I can text it to you.
Reply With Quote
  #6  
Old 05-24-2018, 01:19 PM
Wheelin98TJ Wheelin98TJ is offline
TT Enthusiast
 
Join Date: Jul 2015
Boat: 2005 XStar
Location: Devils Lake
Posts: 159
Thanks for the replies everyone!

My oil filter is also remote mounted up high.

I see if I can get some pics later that show what is going on here.
Reply With Quote
  #7  
Old 05-24-2018, 02:43 PM
Wheelin98TJ Wheelin98TJ is offline
TT Enthusiast
 
Join Date: Jul 2015
Boat: 2005 XStar
Location: Devils Lake
Posts: 159
Checked the owners manual and the oil filters are listed there. Go figure.

But they list the same oil filter part # for all motors on pg 17-3, and they list a different part # for the 8.1L on pg 5-3. So I'm not sure if I can be confident in the info being provided.

The PF25 listed for the LQ9 cross references to the Napa 1069 filter I used. And that filter did not fit well, so back to square one I guess.

Name:  MC oil filters all engines.jpg
Views: 31
Size:  92.1 KB

Name:  MCX 5.7L specs.jpg
Views: 32
Size:  152.6 KB

Name:  LQ9 6.0 specs.jpg
Views: 32
Size:  141.2 KB

Name:  L18 8.1L specs.jpg
Views: 32
Size:  148.3 KB

Last edited by Wheelin98TJ; 05-24-2018 at 03:04 PM. Reason: Resized pics
Reply With Quote
  #8  
Old 05-25-2018, 08:38 AM
Wheelin98TJ Wheelin98TJ is offline
TT Enthusiast
 
Join Date: Jul 2015
Boat: 2005 XStar
Location: Devils Lake
Posts: 159
Here is the damaged oil filter:

Name:  Oil filter.jpg
Views: 19
Size:  85.5 KB


The bolt head that caused it:

Name:  Bolt head.jpg
Views: 19
Size:  52.7 KB


So I used a shorter PF454 oil filter, Napa part #7099, and it seems to fit much better:

Name:  Short oil filter.jpg
Views: 19
Size:  108.5 KB
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:51 AM.


2018