Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 03-24-2010, 08:37 PM
nautibynature nautibynature is offline
TT Enthusiast
 
Join Date: Mar 2010
Boat: 1989 Prostar 190 for sale, 1994 Prostar 190
Location: Mid Atlantic
Posts: 100
leaking speedo ?

I took the boat out today and there was a steady stream of water that was coming from the dash. I took the dash off thinking I would see the speedo tube was disconnected. They were both connected. The speedo on the left had some water in it. Any ideas? 89 prostar 190. Thanks. 1st post btw.
Reply With Quote
  #2  
Old 03-24-2010, 09:10 PM
Chicago190's Avatar
Chicago190 Chicago190 is offline
MC Devotee
 
Join Date: May 2007
Boat: Mastercraft, Prostar 190, 1996, 285 HP
Location: Glenview, IL/Minocqua, WI
Posts: 1,122
Quote:
Originally Posted by nautibynature View Post
I took the boat out today and there was a steady stream of water that was coming from the dash. I took the dash off thinking I would see the speedo tube was disconnected. They were both connected. The speedo on the left had some water in it. Any ideas? 89 prostar 190. Thanks. 1st post btw.
Probably a busted diaphragm in the gauge. I had the same problem, and it's relatively common. Unfortunately, the diaphragm cannot be bought, and you'll need a new gauge. Luckily there is a company that sells them new (http://www.airguide.com.au/index.php?p=1_1) and you can buy them used from anyone who has added Perfect Pass.
__________________
1996 Prostar 190, 350 TBI and Powerslot
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:52 PM.