Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #511  
Old 05-16-2015, 10:48 PM
mts205 mts205 is online now
TT Newbie
 
Join Date: Mar 2015
Boat: 1992 Prostar 205
Location: Midwest
Posts: 28
Throw mine in the mix, 92 prostar 205, 1450lbs rear, about 625 front, about 11-12 mph?, my gate needs to be little longer, but looks promising
Attached Images
 
Reply With Quote
  #512  
Old 05-16-2015, 11:26 PM
dvsone79's Avatar
dvsone79 dvsone79 is offline
TT Enthusiast
 
Join Date: Jul 2012
Boat: '99 205V
Location: Bama
Posts: 355
Quote:
Originally Posted by mts205 View Post
Throw mine in the mix, 92 prostar 205, 1450lbs rear, about 625 front, about 11-12 mph?, my gate needs to be little longer, but looks promising
Looks good mts. Any pics of the wake gate?
Reply With Quote
  #513  
Old 05-16-2015, 11:38 PM
mts205 mts205 is online now
TT Newbie
 
Join Date: Mar 2015
Boat: 1992 Prostar 205
Location: Midwest
Posts: 28
The pic doesn't do it justice. I just threw a make shift gate together this morning out of 2x10 and 2x4s just to test today, will post pics when I remake it.
Reply With Quote
  #514  
Old 05-17-2015, 08:32 AM
FoggyNogginz's Avatar
FoggyNogginz FoggyNogginz is offline
MC Fanatic
 
Join Date: Aug 2006
Boat: 1998 PS205, then a 2002 X9, and now a 2012 X14V
Location: Center Hill Lake & Old Hickory
Posts: 939
Love to see folks surfing on a direct drive. Nice work!
__________________
----------------------------------

"KC"

Cmon...lemme just push one button...
- Red X14V on Center Hill & Old Hickory lakes in TN -
Reply With Quote
  #515  
Old 05-17-2015, 06:12 PM
frankster1969's Avatar
frankster1969 frankster1969 is offline
TT Regular
 
Join Date: Mar 2015
Boat: Mastercraft, X-10 2005, MCX 5.7
Location: Southeast
Posts: 69
Finished the first prototype for the X-10. Not the prettiest, but it works... It really smoothed out the wake and I was able to ride without the rope for the first time...
Attached Images
    
Reply With Quote
  #516  
Old 05-19-2015, 12:37 AM
lashburn1's Avatar
lashburn1 lashburn1 is offline
MC Devotee
 
Join Date: Aug 2013
Boat: 2014 X30 5.7- 2006- 200 SS 5.7 -2013 X30 6.2
Location: Oceanside California
Posts: 1,869
Quote:
Originally Posted by frankster1969 View Post
Finished the first prototype for the X-10. Not the prettiest, but it works... It really smoothed out the wake and I was able to ride without the rope for the first time...
Nice Wake..

...What the Heck is in your Water? it looks Dark Brown?? is that just the Light??
__________________

2014 X30 GEN2 5.7
2006 VRS200 5.7
2013 X30 GEN2 6.2
Think before I post ..."Do I need to say this? Or should I just let someone else complain "
Reply With Quote
Reply

Tags
2007 x2, ballast setup, surf setup, wake plates, wakesurfing

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:51 PM.