Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 06-18-2018, 10:24 AM
[email protected] bbensten@gmail.com is offline
TT Newbie
 
Join Date: Nov 2016
Boat: Mastercraft X2 2012
Location: Northeast
Posts: 11
2012 X2 Depth Blank

This weekend, my 2012 X2 stopped showing depth at all. In the digital view, it shows 0.0 and the "analog" view is blank.

I am assuming the transducer is bad but I am having a hard time finding the replacement part.

The Tag Shows:
Airmar PN: 44-136-2-01 REV 3
Customer Part Number : 7050-11000-01.

Does anyone have any ideas where to get a new transducer? I would have assumed these would be easy to find and since it has not been, I am questioning my diagnosis.
Attached Images
 

Last edited by [email protected]; 06-18-2018 at 10:34 AM. Reason: added image
Reply With Quote
  #2  
Old 06-18-2018, 06:39 PM
ccelia's Avatar
ccelia ccelia is offline
TT Enthusiast
 
Join Date: Jun 2009
Boat: 2009 Mastercraft X-45
Location: Mid-Atlantic
Posts: 372
You are on the right path - I believe if you look up Airmar Triducer DST800-N2000 you will find plenty of places online that sell a replacement for you.
Reply With Quote
  #3  
Old 06-18-2018, 07:08 PM
[email protected] bbensten@gmail.com is offline
TT Newbie
 
Join Date: Nov 2016
Boat: Mastercraft X2 2012
Location: Northeast
Posts: 11
Yes, I saw that as an option but it looks like the cable/pin layout is totally different and although there is another tread on the topic (https://www.mastercraft.com/teamtalk...ad.php?t=75847) , nobody solved if you can make the Airmar work instead of the MC part #509135. Does anyone know?
Reply With Quote
  #4  
Old 07-09-2018, 12:37 PM
[email protected] bbensten@gmail.com is offline
TT Newbie
 
Join Date: Nov 2016
Boat: Mastercraft X2 2012
Location: Northeast
Posts: 11
The Triducer was my issue. Replaced it easily and all is working now.

If anyone is looking for the Mastercraft Part, I found it here: https://shop.southfloridamarine.com/...uctId=-6017133
Reply With Quote
Reply

Tags
2012 x2, depth finder, depth gauge reads bad, transducer

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:15 PM.


2018