Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #11  
Old 06-22-2011, 10:30 AM
agarabaghi agarabaghi is offline
MC Maniac
 
Join Date: Mar 2011
Boat: 1994 Mastercraft Prostar 205
Location: Southeast
Posts: 3,165
I guess it would help if the OP would tell us what year his boat was.
Reply With Quote
  #12  
Old 06-22-2011, 10:50 AM
JRW160's Avatar
JRW160 JRW160 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: 2003 X2
Location: Huntsville, AL
Posts: 1,387
Quote:
Originally Posted by CantRepeat View Post
What year is your boat? On my 06 I have at least a 2.5 inch and could be a 3 inch thru hull with 1 inch feeder lines.
Mine is a 2003 X2.
Reply With Quote
  #13  
Old 06-22-2011, 10:55 AM
JRW160's Avatar
JRW160 JRW160 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: 2003 X2
Location: Huntsville, AL
Posts: 1,387
Quote:
Originally Posted by kevkan View Post
I've got a 2008 X-1. I fill the tanks till water comes out the side of the boat. But when draining, is there some way to know when the tanks are empty?
I haven't looked, but I assume on mine there is a check valve on the fill line and that is how water is forced out the sides of the boat when draining. I could be completely wrong, but it doesn't seem like that we be much trouble to add.
Reply With Quote
  #14  
Old 06-22-2011, 11:06 AM
JRW160's Avatar
JRW160 JRW160 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: 2003 X2
Location: Huntsville, AL
Posts: 1,387
Quote:
Originally Posted by agarabaghi View Post
I guess it would help if the OP would tell us what year his boat was.
OP boat's is a 2006 X45 according to his sig
Reply With Quote
  #15  
Old 06-22-2011, 11:49 AM
agarabaghi agarabaghi is offline
MC Maniac
 
Join Date: Mar 2011
Boat: 1994 Mastercraft Prostar 205
Location: Southeast
Posts: 3,165
weird i cant see any sigs.
Reply With Quote
  #16  
Old 06-22-2011, 12:27 PM
kevkan kevkan is offline
TT Enthusiast
 
Join Date: Aug 2009
Boat: Mastercraft 2008 X-1
Location: midwest
Posts: 340
Yes, the 08 X-1 drains out the bottom, but does not have any guages, and I'm pretty sure there isn't a timer. I've been opening the center locker to watch the bag empty and knocking on the side of the tanks to determine if they are empty. I don't much care for the design.

I'm considering replacing the tanks with 750 lb bags, and adding the v shaped bag under the front. Just not sure if I wan't that much weight.
Reply With Quote
  #17  
Old 06-22-2011, 12:37 PM
JRW160's Avatar
JRW160 JRW160 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: 2003 X2
Location: Huntsville, AL
Posts: 1,387
Quote:
Originally Posted by kevkan View Post
Yes, the 08 X-1 drains out the bottom, but does not have any guages, and I'm pretty sure there isn't a timer. I've been opening the center locker to watch the bag empty and knocking on the side of the tanks to determine if they are empty. I don't much care for the design.

I'm considering replacing the tanks with 750 lb bags, and adding the v shaped bag under the front. Just not sure if I wan't that much weight.
I just replaced my factory hard tanks with 750s, and I also havethe ski locker sack and the v shaped bag up front. You are going to need more weight in the nose if you plan on filling the 750s. When I fill the 750s, I have a 350lb sack in the walkway and another 350lb sack laying perpindicular to it across the seats in the bow. If I had to do it over again, I might have just gone with 550s instead.

Also, I'm not sure what the stock prop is on an 08 x1, but I had a 14x20 prop on mine, and it would barely plane out with the boat weighted. I just switched to a 14.2x14.5, and everything is fine.
Reply With Quote
  #18  
Old 06-22-2011, 01:58 PM
emnesto emnesto is offline
TT Regular
 
Join Date: Jun 2006
Boat: 2006 X45 LQ9
Location: Midwest
Posts: 95
Thanks for all your help. My boat is an '06 X45, and I do get water out the sides when emptying. Do the guages reflect actual liquid in the tank, or the length of time the pump is running. I finally got all guages to empty, and I'm going to turn batteries off, then on, to reset the system. I'm also planning on replacing all 3 impellers this weekend with green. I'm still on the original impellers, so that should help.
__________________
2006 X-45 LQ9
2005 Yukon Denali
Reply With Quote
Reply

Tags
ballest, operation, pump

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:27 AM.


2018