Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 10-07-2018, 07:54 PM
stanhastheplan stanhastheplan is offline
TT Newbie
 
Join Date: Jul 2014
Boat: 2001 X-10
Location: Texas
Posts: 21
Talking 2001 X-10 5.7 TBI How to set timing?

I have a MEFI3 controller, so I turned off timing advance and the engine died. It was running very good with Mefi control. So i turned the distributor some and restarted and got the timing light out but can't seem to get it timed to zero with the timing light set to 10 degrees. *My timing light has a variable knob on the back that you set to manuf recommendation. I am guessing that for my boat it's 10 degrees, hoping someone can confirm.

When i just set the distributor where it sounds the best and then turn on mefi control the timing shows around 12 degrees via the screen.

Any ideas, am I doing this right?
Reply With Quote
  #2  
Old 10-10-2018, 10:58 AM
stanhastheplan stanhastheplan is offline
TT Newbie
 
Join Date: Jul 2014
Boat: 2001 X-10
Location: Texas
Posts: 21
bump

bump, bump, bump, bump, bump
Reply With Quote
  #3  
Old 10-10-2018, 01:46 PM
Cumminscj Cumminscj is offline
TT Enthusiast
 
Join Date: Oct 2016
Boat: 86 Magnum Skier
Location: Southeast
Posts: 281
You don't say how you turned off the mefi control, but in order to time it you put it into diagnostic mode, raise the rpms to 1,000 and set it to 10 degrees. If the timing is jumping around you likely don't have it in the proper diagnostic mode. It should be easy.
__________________
1986 Marlin Magnum Skiier-sold
2000 Maristar 210VRS-weekend ride
1996 205 with LT1 cracked block-winter project
Reply With Quote
  #4  
Old 10-10-2018, 01:50 PM
stanhastheplan stanhastheplan is offline
TT Newbie
 
Join Date: Jul 2014
Boat: 2001 X-10
Location: Texas
Posts: 21
I happen to have a Diacom MEFI controller. There is a mode called "Base Timing" that I used where it rev's up the engine to 750~ rpm or so and definitely turns off computer based timing control. I wonder if something is up with that? It only seems to run good under mefi control.
Reply With Quote
  #5  
Old 10-10-2018, 02:43 PM
Cumminscj Cumminscj is offline
TT Enthusiast
 
Join Date: Oct 2016
Boat: 86 Magnum Skier
Location: Southeast
Posts: 281
That sounds right as long as the timing is steady when you go to set it. It generally does not run well and you need to raise the rpms to 1,000
__________________
1986 Marlin Magnum Skiier-sold
2000 Maristar 210VRS-weekend ride
1996 205 with LT1 cracked block-winter project
Reply With Quote
Reply

Tags
5.7, mefi, tbi, timing

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:39 AM.


2018