Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 04-27-2018, 02:20 PM
seubank seubank is offline
TT Newbie
 
Join Date: Apr 2018
Boat: mastercraft stars&stripes 1981 350 winsor
Location: n central
Posts: 1
engine

my 81 MC 351 Windsor at the back of the motor were the transmission bolt up white smoke coming out of seem when running don"t know why? any suggestion what it is.
Reply With Quote
  #2  
Old 04-27-2018, 02:48 PM
88 PS190 88 PS190 is online now
MC Maniac
 
Join Date: Aug 2005
Boat: 1988 MC Prostar 190, 351 Ford
Location: Midwest
Posts: 4,330
Send a message via AIM to 88 PS190
That ain't right!

Smell? Oil level in engine and transmission?

Grab some clean paper towel and rub it around under the trans and engine - any red fluid? any oil?
Reply With Quote
  #3  
Old 04-27-2018, 03:33 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 17,130
Send a message via Skype™ to mikeg205
white smoke or steam? I bet a leaky manifold gasket and smoke more gray? If you are running original - exhaust manifolds and risers - they may have given up their ghost
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:42 AM.


2018