Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 04-24-2018, 10:48 PM
systembuilder's Avatar
systembuilder systembuilder is offline
TT Regular
 
Join Date: Apr 2018
Boat: 1992 Prostar 190
Location: VA
Posts: 62
So what IS the new directive for Transmission fluid on a 1992 or older Prostar?

So, as a new thread.....

People hollering everything from "Help me Mommy: to "Help me Jesus" with the threads on transmission slippage.

MY case was that I got slippage under coming up to plane, others had it with towing, etc. Same issue, under load.

My fix was to drain and replace the old Mercon with Mecon 5 (V) and overfill a pint while hot.

No rebuild, just drain and replace. And overfill a touch, because I got the same slippage after rebuiiding both plates.

The new fluid is thinner, and science remains, these are pressure-driven transmissions.

Not rocket science, add a pint or two if you have to overfill, just don't blow your seals.

Hooking up a pressure kit to your tranny will cost bucks, and you will be low pressure. Plus, if your seals are bad you will see fluid in the bilge anyway. If that is the case, replace the seals.

Regards.

James
Reply With Quote
  #2  
Old 04-25-2018, 08:42 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 17,560
Send a message via Skype™ to mikeg205
Did you consider that your pump may be worn. After speaking with ZF .. in my case.. there should be no slip with regular or synthetic blend fluid. 100% synthetic the manufacture said that the friction modifiers were not compatible with the older marine transmissions.

I see your back with some constructive critiscm
.

Sent from my SM-G955U using Tapatalk
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #3  
Old 04-26-2018, 06:43 AM
88 PS190 88 PS190 is offline
MC Maniac
 
Join Date: Aug 2005
Boat: 1988 MC Prostar 190, 351 Ford
Location: Midwest
Posts: 4,067
Send a message via AIM to 88 PS190
Mine slipped a bit. Sucked off some atf bottle of seafoam trans tune ran it hard for a bit then sucked that out for some new dex III. Like a champ.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:18 PM.


2018