Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 06-11-2009, 11:17 AM
Willytown Willytown is offline
TT Enthusiast
 
Join Date: Jun 2007
Boat: X-Star
Location: Midwest
Posts: 209
2006 X-Star amp setup

I am currently doing some stereo upgrades and Im trying to figure out what amps are pushing what. I briefly looked last night and was pulling RCA's to identify what was what. I have a 6 channel and a 2 channel. It looks like 4 channels (of th6) are bridged and pushing hte 6 interior speakers. The other 2 channels (of 6) are pushing the sub. That would mean the 2 channel amp was pushing all 4 tower speakers (that doesnt seem right but thats the way it looks). I already removed the tower speakers so dont have a quick way to test.
Reply With Quote
  #2  
Old 06-11-2009, 11:25 AM
Ole Miss Rebels's Avatar
Ole Miss Rebels Ole Miss Rebels is offline
MC Fanatic
 
Join Date: Jun 2006
Boat: 2008 X-Star, Red and Black, L18
Location: eagle lake, mississippi
Posts: 586
that is exactly how my 05 xstar was hooked up. way, way underpowered. kept going into thermal shutdown. i have since added two more amps for a total of four. i am fixing to swap the jl tower speakers for four (4) wetsounds pro 80's and at that time i will replace the current tower amp 4 X 75 alpine with two (2) wetsounds syn 2 amps. that should make the neighbors happy on a sunday morning when star star by the rolling stones is playing ;-)
__________________


"Tropic corridor, tropic treasure. What got us this far to this mild equator? We need someone, something new....something else to get us through" (James Douglas Morrison/The Doors)
Reply With Quote
  #3  
Old 06-11-2009, 11:57 AM
Willytown Willytown is offline
TT Enthusiast
 
Join Date: Jun 2007
Boat: X-Star
Location: Midwest
Posts: 209
i was reallly suprised to see a 2 channel amp pushing 4 tower speakers...i am installing 2 wetsounds 485's with a syn 4 (800 watt, 2 x 400) amp. im also planning to pull better wire to the tower.

Thanks!
Reply With Quote
  #4  
Old 06-11-2009, 12:03 PM
btriantos's Avatar
btriantos btriantos is offline
TT Enthusiast
 
Join Date: Jul 2008
Boat: 2018 X23, 6000GDI
Location: West coast
Posts: 428
Yep, it's not the number of channels that's the problem, it's the watt output that matters at a particular ohm rating. 600+watts into those four tower speakers should do the trick, and getting a dedicated monoblock for the sub will help a lot
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:04 PM.


2018