Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #1  
Old 09-08-2013, 06:46 PM
GoinBoatin's Avatar
GoinBoatin GoinBoatin is offline
TT Enthusiast
 
Join Date: Jan 2013
Boat: 2006 x-45 8.1L
Location: Iowa
Posts: 319
Attitude plate broken mount

Does anyone know if, and where, I could get a new bracket that mounts my lenco Plate motor to the transom. I'd rather not have to buy the whole unit if I don't have to.
Reply With Quote
  #2  
Old 07-02-2018, 11:06 AM
kecusc kecusc is offline
TT Regular
 
Join Date: Aug 2014
Boat: 2006 X45, 2004 X30
Location: Southwest
Posts: 82
Trim tab mounting bracket

Hi, I know this is an old post but wondering if you ever found a solution. I have the same boat and just got home from the lake to find the bracket broken. Wondering what my next steps are.
Reply With Quote
  #3  
Old 07-02-2018, 11:27 AM
lakedrum03's Avatar
lakedrum03 lakedrum03 is offline
TT Enthusiast
 
Join Date: Jul 2017
Boat: 2003 X-Series MCX
Location: Ohio
Posts: 473
Could you post a photo or two?
__________________
Being on a boat that's moving through the water, it's so clear. Everything falls into place in terms of what's important and what's not. - James Taylor
Reply With Quote
  #4  
Old 07-02-2018, 11:35 AM
kecusc kecusc is offline
TT Regular
 
Join Date: Aug 2014
Boat: 2006 X45, 2004 X30
Location: Southwest
Posts: 82
Pics of broken trim tab bracket

Hereís a couple pics. Also, just found the part on MCpartsdepot.com.

https://mcpartsdepot.com/products/br...arss-06-14-s-s

Now I just need to figure out how to install it. The cable goes through the bracket which makes it more difficult. Anyone have an advice?
Attached Images
  
Reply With Quote
  #5  
Old 07-02-2018, 11:47 AM
lakedrum03's Avatar
lakedrum03 lakedrum03 is offline
TT Enthusiast
 
Join Date: Jul 2017
Boat: 2003 X-Series MCX
Location: Ohio
Posts: 473
Just get the replacement mount direct from Lenco. You will pay a premium for the MC logo on it.
__________________
Being on a boat that's moving through the water, it's so clear. Everything falls into place in terms of what's important and what's not. - James Taylor
Reply With Quote
  #6  
Old 07-02-2018, 11:50 AM
kecusc kecusc is offline
TT Regular
 
Join Date: Aug 2014
Boat: 2006 X45, 2004 X30
Location: Southwest
Posts: 82
I read in another post from a guy with the same boat and this part isn’t made by Lenco. Apparently it’s made by MC and has the angled shape to fit the hull.
Reply With Quote
  #7  
Old 07-02-2018, 11:53 AM
lakedrum03's Avatar
lakedrum03 lakedrum03 is offline
TT Enthusiast
 
Join Date: Jul 2017
Boat: 2003 X-Series MCX
Location: Ohio
Posts: 473
Quote:
Originally Posted by kecusc View Post
I read in another post from a guy with the same boat and this part isnít made by Lenco. Apparently itís made by MC and has the angled shape to fit the hull.
ok. Please excuse my ignorance. I just looked in the Lenco catalog and didn't see anything that looked the same.
__________________
Being on a boat that's moving through the water, it's so clear. Everything falls into place in terms of what's important and what's not. - James Taylor
Reply With Quote
  #8  
Old 07-02-2018, 11:56 AM
kecusc kecusc is offline
TT Regular
 
Join Date: Aug 2014
Boat: 2006 X45, 2004 X30
Location: Southwest
Posts: 82
No worries. Any and all advice is appreciated. $60 certainly isn’t cheap for such a part but nothing for boats seems to ever be cheap! Haha.
Reply With Quote
  #9  
Old 07-14-2018, 10:28 PM
kecusc kecusc is offline
TT Regular
 
Join Date: Aug 2014
Boat: 2006 X45, 2004 X30
Location: Southwest
Posts: 82
Got the bracket in the mail from MC Parts Depot and installed it today. A bit of a chore having to pull the actuator cable through and back again but other than that not too bad. The replacement bracket seems to be more heavy duty than the cracked one which I think was aluminum. Hopefully I got everything sealed up nicely with no leaks.


Sent from my iPhone using Tapatalk
Reply With Quote
  #10  
Old 08-06-2018, 10:45 PM
Red45 Red45 is offline
TT Newbie
 
Join Date: Jul 2018
Boat: 2006 x45
Location: West Coast
Posts: 6
This happened to me this weekend and now I will be replacing the bracket with the boat on the lift. Would like to avoid as many surprises as possible. Any tips? What kind of sealant did you use? Looks like you pulled out the entire wire. Does it run all the way to the dash? Any way to splice it? Thanks in advance!


Sent from my iPhone using Tapatalk
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 04:31 PM.


2018