Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Trailers

Reply
 
Thread Tools Display Modes
  #11  
Old 07-17-2018, 11:21 AM
hyman989's Avatar
hyman989 hyman989 is offline
MC Fanatic
 
Join Date: May 2016
Boat: 2015 Mastercraft NXT20
Location: pacific northwest
Posts: 513
Quote:
Originally Posted by stuartjr View Post
Thoughts on disconnecting lights from vehicle before launching? Noticed the outer shell on my wiring harness has split in a couple of places, one of which is completely submerged when launching. No bare wires yet but worried about damaging something. 2015 X10 for reference.
Should be covered by the no question 5 year warranty if your the first owner or second if you paid the transfer fee

Sent from my SM-G955U using Tapatalk
Reply With Quote
  #12  
Old 07-17-2018, 11:40 AM
stuartjr stuartjr is offline
TT Regular
 
Join Date: Jul 2016
Boat: 2015 X10
Location: Southeast
Posts: 43
Quote:
Originally Posted by bturner2 View Post
Depends on the trailer and lights.

Disk brakes and LED lights - leave connected
Drum brakes and incandescent lights - disconnect

Depending on your ramp angle you could lock up your brakes with the power disconnected without using a lock out pin for the actuator. Also with LED sealed lights your chances for problems are very limited. I've been leaving my power connect on the last 2 boats with LED lights and disc brakes since 2005 with zero issues.

As a side note having bare wires on your harness is going to be a problem with or without adding water to the equation. The smart move is going to be to properly repair/replace the wiring now before you have an issue. Small problem like this tend to turn into real problems when you can least afford them (like driving home from vacation late at night).
Agree with getting it fixed and I have emailed my dealer about it. I'm hoping it can be replaced under warranty but I will replace regardless. I think my concern is more about how quickly and easily it split. The boat/trailer has less than 3 seasons on it. Seems like this is going to be a continual problem so wanted to see what others are doing.
Reply With Quote
  #13  
Old 07-17-2018, 11:51 AM
stuartjr stuartjr is offline
TT Regular
 
Join Date: Jul 2016
Boat: 2015 X10
Location: Southeast
Posts: 43
Quote:
Originally Posted by hyman989 View Post
Should be covered by the no question 5 year warranty if your the first owner or second if you paid the transfer fee

Sent from my SM-G955U using Tapatalk
I am the original owner so that's my hope. They are checking for me.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:50 AM.


2018