Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 07-16-2014, 02:38 AM
JPust JPust is offline
TT Newbie
 
Join Date: Jul 2014
Boat: 2011 Matercraft x-25 5.7ilmor
Location: Northwest
Posts: 5
Engine Problems

Hi,

I have a 2011 mastercraft x-25 with the 5.7 ilmor engine. I am currently running the stock prop and I cannot get to plane with 2500 lbs in the boat. Also the engine emits a fair amount of white smoke which is especially noticeable while surfing. I went to my dealer several times to get the boat serviced and checked for the lack of power and white smoke but he says everything is fine. My boat is run at high altitude in warm water (approx. 85F). I am leaning towards this being an issue where the engine is injecting the fuel to rich, or possibly there is a problem with the cooling system.

Has anyone else seen this problem, or knows of it?
Reply With Quote
  #2  
Old 07-16-2014, 09:11 AM
76S&S's Avatar
76S&S 76S&S is offline
MC Devotee
 
Join Date: Jun 2007
Boat: 2002 X Star
Location: Lake Tuscaloosa, AL
Posts: 2,337
Welcome to the forum and sorry to hear of your troubles.

Given the weight that you are running and you didn't state how many peeps on board, what prop are you running?
__________________
Being on the water is best, but when I'm not on the water I'm on TT.

2002 X Star
Sold - 76 S&S
Reply With Quote
  #3  
Old 07-16-2014, 09:16 AM
JPust JPust is offline
TT Newbie
 
Join Date: Jul 2014
Boat: 2011 Matercraft x-25 5.7ilmor
Location: Northwest
Posts: 5
2500 lbs is what I estimate the total added weight with the ballast plus people, gear and fuel
Reply With Quote
  #4  
Old 07-16-2014, 09:17 AM
JPust JPust is offline
TT Newbie
 
Join Date: Jul 2014
Boat: 2011 Matercraft x-25 5.7ilmor
Location: Northwest
Posts: 5
Sorry that's not get clear, 2500 includes ballast people gear and fuel
Reply With Quote
  #5  
Old 07-16-2014, 09:26 AM
JPust JPust is offline
TT Newbie
 
Join Date: Jul 2014
Boat: 2011 Matercraft x-25 5.7ilmor
Location: Northwest
Posts: 5
Also I was running the stock prop (not sure what it is) then I switched to OJ 4 blade 14 x 14.25. The new prop didn't change getting on plane, and there still is quite a lot of white smoke.
Reply With Quote
  #6  
Old 07-16-2014, 10:30 AM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 17,242
Send a message via Skype™ to mikeg205
You probably need a different prop - are you seeing white steam not smoke? Smell gas as stern?

what is temp gauge read when you see white smoke?
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #7  
Old 07-16-2014, 11:05 AM
JPust JPust is offline
TT Newbie
 
Join Date: Jul 2014
Boat: 2011 Matercraft x-25 5.7ilmor
Location: Northwest
Posts: 5
I read on the other forums, the 4 blade acme is what they recommend (what I have on now), or the 5 blade.

The white smoke smells distinctly of gas, it's quite a strong odour.
Reply With Quote
  #8  
Old 07-16-2014, 11:11 AM
cwarndahl's Avatar
cwarndahl cwarndahl is offline
MC Devotee
 
Join Date: Dec 2011
Boat: X-45 finally better then x-10
Location: Austin, TX
Posts: 1,404
Engine Problems

Defiantly need a new prop, I'm trading my acme 1285 for the 2231. But being high altitude my prop choices may not be right for you. I have the 1285 and it was a ton better almost like getting a bigger engine. But yesterday I hade 3000 pounds in the boat and was again slow to get on plane. I have no idea what steam/smoke may be. The only thing I can think of, is the front ballast pump in these boats is mounted in front of the transmission, and mounted wrong, or at least im told, I checked mine yesterday and it was leaking real close to the trans, that's just idea not a proven solution.
__________________
2012 MC X-25
Reply With Quote
Reply

Tags
engine, poor performance, white smoke

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:19 PM.