Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

Reply
 
Thread Tools Display Modes
  #7211  
Old 05-05-2018, 06:30 PM
lakedrum03's Avatar
lakedrum03 lakedrum03 is offline
TT Enthusiast
 
Join Date: Jul 2017
Boat: 2003 X-Series MCX
Location: Ohio
Posts: 406
Cleaned her up. Should Be ready for the water next weekend

Name:  4C342C94-60DA-4626-B656-69E51D7B09D1.jpg
Views: 585
Size:  151.8 KB

Name:  55370FE6-DB4F-4374-AF3E-25578EAC31CE.jpg
Views: 591
Size:  144.2 KB

Name:  C21DCA25-2F8F-4792-902D-67C822B19381.jpg
Views: 590
Size:  153.2 KB
__________________
Being on a boat that's moving through the water, it's so clear. Everything falls into place in terms of what's important and what's not. - James Taylor
Reply With Quote
  #7212  
Old 05-05-2018, 09:07 PM
Black n Green's Avatar
Black n Green Black n Green is offline
TT Regular
 
Join Date: Dec 2017
Boat: 2017 XT21 6000GDI
Location: Lake Nacimiento, CA
Posts: 60
100 hour oil change

First time using a pump through the dipstick tube. Why have I not used one of these before now? Made the job easy and zero mess.

Oil flows through the tube so much easier when it is warm. Used 4 hours of surfing to prep the oil before extraction.
Attached Images
  
Reply With Quote
  #7213  
Old 05-06-2018, 08:37 PM
lakedrum03's Avatar
lakedrum03 lakedrum03 is offline
TT Enthusiast
 
Join Date: Jul 2017
Boat: 2003 X-Series MCX
Location: Ohio
Posts: 406
303 fabric guard on the cover.

Name:  E9EFAA29-DB47-442D-83C0-C32FE5D36655.jpg
Views: 502
Size:  153.5 KB

Name:  C4FFAC43-B32C-4F79-9D08-787E42519D3C.jpg
Views: 497
Size:  152.5 KB
__________________
Being on a boat that's moving through the water, it's so clear. Everything falls into place in terms of what's important and what's not. - James Taylor
Reply With Quote
  #7214  
Old 05-08-2018, 07:45 AM
dbismyname dbismyname is offline
TT Enthusiast
 
Join Date: Feb 2016
Boat: 1999 205v
Location: Southeast
Posts: 166
Pulled her out of hibernation. Reattached hoses, reinstalled block plugs, put in new impeller. Fired up on fake a lake and ran for 15 mins. Batteries had not even been disconnected or tended since Sept, fired up first turn. Drained oil after running and realized my filter wrench isnt at home and my grease gun doesnt work. So today will be greasing rudder box and finishing oil change. Also gave her a bath and hooked up battery tender. Missing any other spring must dos?



Sent from my iPhone using Tapatalk
Reply With Quote
  #7215  
Old 05-08-2018, 07:53 AM
MattsCraft's Avatar
MattsCraft MattsCraft is offline
MC Devotee
 
Join Date: May 2008
Boat: 2013 X25 - 6.2 Ilmor Baby
Location: Cincinnati, OH
Posts: 1,765
Added some MCOCD Cleats in my rear lockers for ropes & fenders. I had 4 I bought off of Alberta Surfer a couple years back, had no idea what I was going to use them for, I think this will work out nicely!

I did change my tranny fluid (244 hours) - Yes I went with RedLine Type R per the ZF recommendation in that other debate thread on tranny fluid - I could only get a little over 2.5 Qts out, so that is exactly what I put back in - yes I cleaned the metal filter
Attached Images
 
Reply With Quote
  #7216  
Old 05-09-2018, 05:57 AM
bret's Avatar
bret bret is offline
MC Devotee
 
Join Date: Aug 2004
Boat: Prostar 190, 1993, Anniversary Limited.
Location: Heber Springs, AR
Posts: 1,068
Installed my two lifts on B Dock so now, MC and Sea Doo will be in a double on same dock. Some other ski club members on same dock and one dock over on A Dock. Helps to keep an eye on things.


__________________
1993 25th Anniversary Limited ProStar 190, #17
Reply With Quote
  #7217  
Old 05-19-2018, 07:20 AM
mike koen's Avatar
mike koen mike koen is offline
TT Enthusiast
 
Join Date: May 2015
Boat: mastercraft x-14 2008 mcx
Location: Canada
Posts: 385
New cover , replaced swim platform pad and replumb kit done
__________________
If she don't shine , she ain't mine
Reply With Quote
  #7218  
Old 05-19-2018, 07:23 AM
mike koen's Avatar
mike koen mike koen is offline
TT Enthusiast
 
Join Date: May 2015
Boat: mastercraft x-14 2008 mcx
Location: Canada
Posts: 385
Upgrade
Attached Images
 
__________________
If she don't shine , she ain't mine
Reply With Quote
  #7219  
Old 05-19-2018, 06:51 PM
Slinkyredfoot's Avatar
Slinkyredfoot Slinkyredfoot is offline
MC Devotee
 
Join Date: Apr 2006
Boat: 1979 Mastercraft, 1998 ProStar 205
Location: East of Westfield
Posts: 2,107
Started right up after being in storage for 5 plus months. Suds are from lube in impeller works
All the time.
Attached Images
 
__________________
If for some reason you start to believe you are a person with influence, just try ordering somebody else's dog around.
Reply With Quote
  #7220  
Old 05-29-2018, 12:49 PM
ccelia's Avatar
ccelia ccelia is offline
TT Enthusiast
 
Join Date: Jun 2009
Boat: 2009 Mastercraft X-45
Location: Mid-Atlantic
Posts: 357
With rain in the forecast for MDW, I spent the weekend cutting holes in the boat to install another set of JL M770s and a second JL M10IB5 subwoofer. This is the first time I have cut holes in the boat, so it was a little nerve-racking, but I used a dremel with a multi-purpose rotozip bit and the circular cutting attachment and it worked perfectly. The dremel was a slow process (probably 5 minutes per hole), but I felt confident knowing that I was getting a perfect circle. There were a few electronics under the helm that had to be moved, but other than that, it was a straight-forward install.

I am still in the process of wiring up the new MHD amps, but I can't wait to hear the well rounded sound in the cabin.
Attached Images
    
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:44 AM.


2018