Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 07-06-2016, 03:07 PM
Nautique Sports's Avatar
Nautique Sports Nautique Sports is offline
TT Newbie
 
Join Date: Dec 2013
Boat: X45, X30, Barefoot 200
Location: Caribbean
Posts: 9
Exclamation 2008 X-45 400HP indmar vortec power train relay fault

2008 X-45 400 HP indmar vortec, engine is cranking but not firing. Voltage on dash remaing above 10.5v even when cranking and oil pressure rises.
diagnostic software kicking out:
SPN 66014 power train relay contact fault
FMI 4 voltage below normal.
I have just replaced the starter, and batteries.
Can't figure out where the problem would be. happened when the boat is on lift. One day working fine then next day, relay fault and no start.
Any ideas would be greatly appreciated
Reply With Quote
  #2  
Old 07-06-2016, 03:40 PM
neil.anderson63's Avatar
neil.anderson63 neil.anderson63 is offline
MC Maniac
 
Join Date: Dec 2011
Boat: 2007 X2
Location: Somewhere on Tablerock
Posts: 2,598
Safety lanyard secure? Mine gets a little off now and then causing a no start even though it looks like it's attached.
__________________
Screws fall out all the time, the world is an imperfect place.
Reply With Quote
  #3  
Old 07-06-2016, 06:15 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 17,212
Send a message via Skype™ to mikeg205
low voltage - carribean - check for corrosion.. on contacts
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #4  
Old 07-17-2016, 01:12 PM
uliwake uliwake is offline
TT Regular
 
Join Date: Dec 2015
Boat: xstar 2005. xstar 2014 6.2L
Location: middle east
Posts: 60
recently I had an issue with a fuel relay (Indmar MCX 350), we thought it was the relay it was random failure , we changed the relay and the problem remain , so at the end was the relay connector , two of the pins had some "play" and were not contacting properly
Reply With Quote
Reply

Tags
ignition, indmar, relay, x45 ss

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:48 AM.


2018