Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Storage / Winterization

Reply
 
Thread Tools Display Modes
  #11  
Old 09-24-2018, 11:25 AM
Jarome's Avatar
Jarome Jarome is offline
TT Regular
 
Join Date: Nov 2008
Boat: MC XT23 2018 5500 GDI
Location: Alberta
Posts: 52
That sounds like the same info i got from Eric.
__________________
1st boat in 1994 - PS205
2nd boat in 2001 - X Star
3rd boat in 2008 - X2
4th boat in 2018 - XT23
Reply With Quote
  #12  
Old 09-24-2018, 11:37 AM
Jarome's Avatar
Jarome Jarome is offline
TT Regular
 
Join Date: Nov 2008
Boat: MC XT23 2018 5500 GDI
Location: Alberta
Posts: 52
You're right I was surprised by that too, but it did the same when i followed both procedures so I assumed it was right.
Did you remove the anodes on both sides of the block, and the drain plugs on the trans cool and impeller housing? ( all four plugs should be marked with a yellow dot on top of the plug, or at least mine was, but it doesn't say that in the book)
__________________
1st boat in 1994 - PS205
2nd boat in 2001 - X Star
3rd boat in 2008 - X2
4th boat in 2018 - XT23
Reply With Quote
  #13  
Old 09-29-2018, 09:11 PM
cobalt650's Avatar
cobalt650 cobalt650 is offline
TT Enthusiast
 
Join Date: Oct 2013
Boat: 2017 XT23, 5500
Location: Midwest
Posts: 204
Following
__________________
“That’s neat
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:24 PM.


2018