Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #11  
Old 09-11-2013, 06:25 PM
neil.anderson63's Avatar
neil.anderson63 neil.anderson63 is offline
MC Fanatic
 
Join Date: Dec 2011
Boat: 2007 X2
Location: Salt Lake City
Posts: 990
Not sure ef de canadians got a hold of my boat at some time. It's from Nor-Cal Mastercraft ay.
__________________
Screws fall out all the time, the world is an imperfect place.
Reply With Quote
  #12  
Old 05-25-2015, 05:04 AM
Wex007 Wex007 is offline
TT Newbie
 
Join Date: May 2015
Boat: Mastercraft, X2, 2007
Location: Middle East
Posts: 1
Hi Smith14a and niel.anderson63 - I've got a 2007 X2 also and have come accross the same issue where the MC cruise speedo #3 reads differently to the centre speedo #2. Did you guys ever find out how to calibrate or change the units of the MC Cruise speedo?
Reply With Quote
  #13  
Old 05-25-2015, 11:22 AM
neil.anderson63's Avatar
neil.anderson63 neil.anderson63 is offline
MC Fanatic
 
Join Date: Dec 2011
Boat: 2007 X2
Location: Salt Lake City
Posts: 990
Quote:
Originally Posted by Wex007 View Post
Hi Smith14a and niel.anderson63 - I've got a 2007 X2 also and have come accross the same issue where the MC cruise speedo #3 reads differently to the centre speedo #2. Did you guys ever find out how to calibrate or change the units of the MC Cruise speedo?
Got it straightened out. Basically reset the speedo. Got it to where I could choose KPH or MPH. I have a different cruise than yours. If you got speedos #1 and 2 to calibrate but the Perfect Pass speedo isn't calibrating - I'm not sure how to calibrate the PP as I have MC cruise. Friend has the same set up as you and the people at PP walked him through the reset to get it all working right.

EDIT - My cruise is exactly like yours - The total reset fixed mine.
__________________
Screws fall out all the time, the world is an imperfect place.

Last edited by neil.anderson63; 05-26-2015 at 04:51 PM.
Reply With Quote
  #14  
Old 05-27-2015, 03:09 PM
smith14a smith14a is offline
TT Newbie
 
Join Date: May 2013
Boat: 2007 Mastercraft X2
Location: West Michigan
Posts: 27
I did have the dealer reset mine when I winterized it but we ended up switching over to RPM and haven't looked back since. With the added ballast (custom bags from WakeMakers, strongly suggested, great guys) we run around 3,040 - 3,080 RPM and that's a decent speed for most the riders.

Keep me posted on what works for you. I'm curious if you can get the reset to work.
Reply With Quote
Reply

Tags
mc cruise issues, re-calibration, speedo issues

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:15 PM.