Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 09-03-2013, 02:41 PM
smith14a smith14a is offline
TT Newbie
 
Join Date: May 2013
Boat: 2007 Mastercraft X2
Location: West Michigan
Posts: 26
2007 X2 Calibration Question - Speedo/MC Cruise/water temp/etc

Hey Guys,
This is the first summer with my new (new to me) X2. After using an app on my phone I realized that my MC Cruise speedometer was off. It showed 29 MPH when the app said 21 MPH (I tested this on another MC and the app was almost exact. On top of this issue but depth finder, air temp, water temp and time were all off on the other digit gauge (mini screen inside the RPM gauge). I read that you have to hold down the two buttons just left of the steering wheel (I believe they are titled "Speedo" and "Display"). I did this and was able to correct the time, but nothing else would change. I think I tried it one too many times because a few moments later all the arms on every gauage stated going from all the way down, to half, to all the way full, then back to half and back to zero. They did this for about 5 or so times then they went back to normal with the exception of my MPH Speedo gauge. That stays at zero now even with the throttle down. I still haven't been able to fix my MC Cruise either.

Has anyone else had similar issues or know how to fix this? Any help would be great! If you want to chat on the phone off line PM me and I'll give you my number, then post the solution for others to see.

Thanks,
Andy
Reply With Quote
  #2  
Old 09-03-2013, 06:21 PM
Kweisner's Avatar
Kweisner Kweisner is offline
TT Enthusiast
 
Join Date: Oct 2012
Boat: 2007 Prostar 197
Location: Southeast
Posts: 449
I think you have several things going on:

First, if you hold ONLY the Display Selector toggle down for a few seconds, the gauges will all do that dance you've described--it's like a diagnostic routine.

Second, to calibrate the speedo, you ONLY use the speedo toggle while running the boat. So if your GPS says 21 and the boat says 19, then you press that toggle UP. If the speedo is faster than the GPS, toggle down.

Now, what I suspect may have happened is that you held the speedo toggle down for so long, it's at the zero mark. Try running the boat and then toggling up to see if you can get the needle to move.
__________________
"This one goes to eleven." 2007 ProStar 197 TT w/MCX and Powerslot.
Reply With Quote
  #3  
Old 09-06-2013, 08:04 AM
smith14a smith14a is offline
TT Newbie
 
Join Date: May 2013
Boat: 2007 Mastercraft X2
Location: West Michigan
Posts: 26
That sounds very feasible. Thanks for the heads up! Do you know how to adjust the air and water temps? I'm not sure where the air temp sensor is but I think the water temp is in the same location as the speedo sensor. Both read very wrong (air has been 32 degrees all summer (Fahrenheit).

Thanks again Kweisner!
Reply With Quote
  #4  
Old 09-09-2013, 10:26 AM
smith14a smith14a is offline
TT Newbie
 
Join Date: May 2013
Boat: 2007 Mastercraft X2
Location: West Michigan
Posts: 26
I was able to get out on the boat yesterday and play around with the toggles a little bit. I was able to use the "Display" button to change the #1 Digital Display (See attached image) and the "Speedo" button to change the #2 Speedo gauge (See attached image). But I was unable to find the button that will adjust the #3 MC Cruise Speedo display (See attached image).

I got the center (#2 Speedo gauge) to match my iphone speed app. They both say 20 MPH when actually going 20 MPH, but when I have the MC Cruise on (set to a crazy high # so it won't limit my speed for testing) to see the digital speed it says 30 MPH. Is there a way to change the MPH displayed on the MC Cruise digital display?
Attached Images
 
Reply With Quote
  #5  
Old 09-09-2013, 10:55 AM
bobx1 bobx1 is online now
MC Fanatic
 
Join Date: Jun 2007
Boat: SOLD 2007 X1
Location: South
Posts: 923
Is it possible the MC Cruise is set for KPH and not MPH? 19 mph is approx 30 kilometers. Dont know how to change the setting but it may not be a calibration problem.

Last edited by bobx1; 09-09-2013 at 12:11 PM.
Reply With Quote
  #6  
Old 09-09-2013, 12:17 PM
neil.anderson63's Avatar
neil.anderson63 neil.anderson63 is offline
MC Fanatic
 
Join Date: Dec 2011
Boat: 2007 X2
Location: Kansas City
Posts: 672
I have the same problem with my 07 X2 - I've heard that there is way to reset the KPH to MPH. Toggle on the dash can calibrate the speedo and is right on with GPS. Full gauge reset does not change anything. Digital reading on cruise is way off. I've tried holding the toggle down to find KPH or MPH - I'm searching for an answer, dealer has no idea how to make the switch, figured we will live with it this year and solve it this off season.
__________________
Screws fall out all the time, the world is an imperfect place.
Reply With Quote
  #7  
Old 09-10-2013, 08:27 AM
smith14a smith14a is offline
TT Newbie
 
Join Date: May 2013
Boat: 2007 Mastercraft X2
Location: West Michigan
Posts: 26
bobx1 - That is a good thought. It never occurred to me to be honest. I'll check it out. Thanks!

neil.anderson63 - I was thinking of waiting this year out as well and talk to the dealer when I winterize. Let me know if you figure it out and I will do the same. Thanks!
Reply With Quote
  #8  
Old 09-10-2013, 09:49 PM
bobx1 bobx1 is online now
MC Fanatic
 
Join Date: Jun 2007
Boat: SOLD 2007 X1
Location: South
Posts: 923
Quote:
Originally Posted by smith14a View Post
.... Both read very wrong (air has been 32 degrees all summer (Fahrenheit)....
I know you mention Fahrenheit but is it possible that the temp is reading C? 32c is close to 90f which may be close to your correct temp in US units? Seems very coincidental.

Did the Canadians get a hold of this boat at some point? No offense intended.
Reply With Quote
  #9  
Old 09-10-2013, 10:12 PM
g-mantrix's Avatar
g-mantrix g-mantrix is offline
TT Enthusiast
 
Join Date: Oct 2010
Boat: matrix sorrento 2006 315 mrcruiser
Location: south east
Posts: 261
To reset metric to imperial or visa versa, hold down the gauge selection button for 3 secs, when prompted select english or metric display, wait a further 3 secs and the display woll return to normal operation
Reply With Quote
  #10  
Old 09-11-2013, 01:28 PM
smith14a smith14a is offline
TT Newbie
 
Join Date: May 2013
Boat: 2007 Mastercraft X2
Location: West Michigan
Posts: 26
Bobx1 - It was in F when it was reading 32 degrees. Now it's stuck in C showing 0-1 degrees. That's a good thought though.

G-mantrix - I tried that a few times (or so I thought), but if you hold down for a few seconds too long (5 I think) it resets all the gauges (moving all the dials 0-50%-100%-50%-0% and so on). I'll have to play with it some more to get it back. It's getting winterized in the next couple weeks so I'll make sure to get the dealers input as well.
Reply With Quote
Reply

Tags
mc cruise issues, re-calibration, speedo issues

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:30 PM.