Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 06-07-2011, 09:35 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,703
Lenco Trim Tab Actuator

Anyone ever have one go bad?

Mine stop working on Sunday. Pull it out this morning and took it apart. Seems the lower seal had gone bad and the gears and motor were full of water.
__________________
Tim
Gone, surfing.
Reply With Quote
  #2  
Old 07-08-2011, 12:49 AM
ColdTurkey's Avatar
ColdTurkey ColdTurkey is offline
TT Regular
 
Join Date: Jan 2011
Boat: 2007 X80STS - Full Octo Wrap
Location: FNQ Australia
Posts: 48
I just had the same exact thing happen to me. It filled with water and hydro locked the actuator. I'm hoping that drying her out and replacing the seal will fix the problem.
__________________
Wrapped 07' X80 - Twin LY6's
Reply With Quote
  #3  
Old 07-08-2011, 02:44 AM
CiscoStu's Avatar
CiscoStu CiscoStu is offline
TT Regular
 
Join Date: Apr 2010
Boat: 2006 X-30, MCX
Location: S. Alberta, Canada
Posts: 132
Same here... Worked fine last year, this year it's worked maybe twice, now nothing. Makes a sound for 'up' when it's already all the way up, but no sound for down...

I'll pull it and let you know if it's full of water...
Reply With Quote
  #4  
Old 07-08-2011, 07:22 AM
CantRepeat's Avatar
CantRepeat CantRepeat is online now
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 8,703
I replaced it. I called lenco and they gave me the number to one of their resellers down in FL.
__________________
Tim
Gone, surfing.
Reply With Quote
  #5  
Old 07-24-2011, 05:08 PM
ColdTurkey's Avatar
ColdTurkey ColdTurkey is offline
TT Regular
 
Join Date: Jan 2011
Boat: 2007 X80STS - Full Octo Wrap
Location: FNQ Australia
Posts: 48
Managed to repair mine, it was only a simple problem in the end. The bottom seal blew out and it filled up with water. Took it all apart, cleaned and dried it all out, buying a new seal this week and all should be good.
__________________
Wrapped 07' X80 - Twin LY6's
Reply With Quote
  #6  
Old 09-04-2013, 03:14 PM
NatesGr8's Avatar
NatesGr8 NatesGr8 is offline
TT Enthusiast
 
Join Date: Jul 2004
Boat: 05 X-45
Location: CT
Posts: 466
Hate to dig up an old thread, but anyone know a good place to order an actuator from? What have you guys paid for yours? Did the self refurb work? Thanks, Nate
__________________
Guns don't kill people, I kill people
Reply With Quote
  #7  
Old 02-04-2014, 01:38 PM
Macker Macker is offline
TT Newbie
 
Join Date: Feb 2014
Boat: x15 2008
Location: midwest
Posts: 3
ACTUATOR REPAIR OR REPLAcement

Anyone know model number for trim actuator on a 2008 x15. Also mine died because water was getting in via wires I believe as core was wearing on swim grid. gonna grind out the grid to make more room. I did get motor to run but gears must be broke. has anyone pulled a unit apart?
Reply With Quote
  #8  
Old 02-04-2014, 01:46 PM
bjames's Avatar
bjames bjames is offline
MC Devotee
 
Join Date: Jul 2011
Boat: 2009 X-Star LY6
Location: Alberta, Canada
Posts: 1,106
I dont see why you couldnt order one from your local MC dealer. I see Ebay has these as well.
__________________
Current: 2009 X-Star, Indmar 6L, 400hp, ZFT3 tower. c/w 1/9 scale R/C PWT X-Star

Owned:
2012 X25
2011 X25
2009 Moomba LSV
2009 Moomba Outback V
2008 Monterey FS180
Pelican 4 set paddle boat
plastic tug boat when I was 4
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 03:59 AM.