Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 08-31-2013, 12:26 AM
CC2MC's Avatar
CC2MC CC2MC is offline
MC Devotee
 
Join Date: Aug 2012
Boat: 2003 Maristar 210 Predator
Location: Alabama
Posts: 1,092
I need HELP

I just installed the PP on my 21 VRS tonight without a hitch, except for the incorrect direct wire harness that PP sent me that is for the Stargazer instead of my Pro model, which should have the paddle wheel cable but doesn't. The boat is still on the trailer and after the install, I powered everything on to make sure everything came up correctly, which it did. After playing with it for a couple of minutes, something just beeped and the check engine light came on. I have done nothing past installing PP and thought that it may be bc of the direct wire harness. A TT member advised me that I would get a double signal if I did not disconnect the brown wire from the MC side of the harness. I did not disconnect the brown wire, so to figure out if that was causing the issue, I unplugged the PP altogether. The check engine light still came on. Does the CE light need to be reset before it can go off and stay off? If so, how is this done? I did read on a later model X2 that it requires 3 complete cycles of warm up and cool down. Is this correct? I really need to find out what is causing the issue in the first place and outside PP, there is nothing out of the ordinary I can think that it would be.

We will have company all weekend so I cannot be without a boat. Thanks for the help.
Reply With Quote
  #2  
Old 08-31-2013, 08:54 AM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 10,814
Send a message via Skype™ to mikeg205
Yes, there's a code in the ECU - I believe the that sequence of 3 cycles will clear codes based on what I have read here.

http://www.mastercraft.com/teamtalk/...ght=paper+clip

Get the code at least -
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #3  
Old 09-02-2013, 09:19 PM
CC2MC's Avatar
CC2MC CC2MC is offline
MC Devotee
 
Join Date: Aug 2012
Boat: 2003 Maristar 210 Predator
Location: Alabama
Posts: 1,092
Thanks Mike. Thankfully, the code cleared itself out and everything worked just fine.
Reply With Quote
  #4  
Old 09-02-2013, 09:25 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 10,814
Send a message via Skype™ to mikeg205
Quote:
Originally Posted by CC2MC View Post
Thanks Mike. Thankfully, the code cleared itself out and everything worked just fine.
Awesome!!!
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 07:04 AM.