Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Ballast

Reply
 
Thread Tools Display Modes
  #41  
Old 07-28-2013, 01:24 AM
g-mantrix's Avatar
g-mantrix g-mantrix is offline
TT Enthusiast
 
Join Date: Oct 2010
Boat: matrix sorrento 2006 315 mrcruiser
Location: south east
Posts: 260
And thanks heaps for the instructions to remove
Reply With Quote
  #42  
Old 07-28-2013, 06:55 PM
tr6coug's Avatar
tr6coug tr6coug is offline
MC Fanatic
 
Join Date: Aug 2007
Boat: Mastercraft 2007 X2 MCX
Location: OR
Posts: 613
Quote:
Originally Posted by g-mantrix View Post
Ok, just removed the module, now to pack and ship to tr6coug )Attachment 98429
No problem! I'll let you know when it arrives.
__________________
'07 Navy Blue X2 MCX
http://www.wakeblaster.com/
Reply With Quote
  #43  
Old 07-28-2013, 07:46 PM
ttu's Avatar
ttu ttu is offline
MC Maniac
 
Join Date: Jun 2005
Boat: 2007 X2 towed by a 2012 Touareg TDI
Location: tulsa
Posts: 3,685
Quote:
Originally Posted by g-mantrix View Post
Ok, just removed the module, now to pack and ship to tr6coug )Attachment 98429
you will be thrilled! just remember to turn them off!
Reply With Quote
  #44  
Old 07-28-2013, 08:00 PM
BrooksfamX2's Avatar
BrooksfamX2 BrooksfamX2 is offline
MC Devotee
 
Join Date: Dec 2011
Boat: 2007 MasterCraft X2
Location: Mid Left Coast
Posts: 1,651
Mine are still going strong after 2 seasons.......... work perfectly!
__________________
MISS "B" HAVEN
2007 X2, Indmar 350 MCX
OJ 522 14.75 x 15.5
2006 F150 SCrew Puller
http://www.crowniehq.net
http://banners.wunderground.com/weat.../OR/Albany.gif
Reply With Quote
  #45  
Old 07-28-2013, 09:19 PM
g-mantrix's Avatar
g-mantrix g-mantrix is offline
TT Enthusiast
 
Join Date: Oct 2010
Boat: matrix sorrento 2006 315 mrcruiser
Location: south east
Posts: 260
Thanks guys, thats what I want to hear. Sent mine off this morning
Reply With Quote
  #46  
Old 08-05-2013, 12:24 PM
TReece TReece is offline
TT Newbie
 
Join Date: Jul 2013
Boat: 2007, X-Star
Location: Edmond, OK
Posts: 7
07-XStar

Timers ready to ship! contact me please tr6coug!

Thanks
Reply With Quote
  #47  
Old 08-05-2013, 01:34 PM
tr6coug's Avatar
tr6coug tr6coug is offline
MC Fanatic
 
Join Date: Aug 2007
Boat: Mastercraft 2007 X2 MCX
Location: OR
Posts: 613
PM back to you!
__________________
'07 Navy Blue X2 MCX
http://www.wakeblaster.com/
Reply With Quote
  #48  
Old 08-06-2013, 04:33 PM
SJ.'s Avatar
SJ. SJ. is offline
TT Regular
 
Join Date: Nov 2012
Boat: 2008 X2
Location: Rocky Mountains
Posts: 86
Got mine reinstalled. tr6coug nailed it, they work perfect. A big thanks!!!
Reply With Quote
  #49  
Old 08-10-2013, 03:35 PM
tr6coug's Avatar
tr6coug tr6coug is offline
MC Fanatic
 
Join Date: Aug 2007
Boat: Mastercraft 2007 X2 MCX
Location: OR
Posts: 613
Quote:
Originally Posted by SJ. View Post
Got mine reinstalled. tr6coug nailed it, they work perfect. A big thanks!!!
Cool! Glad I could help.
__________________
'07 Navy Blue X2 MCX
http://www.wakeblaster.com/
Reply With Quote
  #50  
Old 08-20-2013, 12:04 PM
Bungee55 Bungee55 is offline
TT Newbie
 
Join Date: Jul 2013
Boat: 1992 Prostar 205, 2008 Xstar
Location: Southeast
Posts: 4
I have extra ballast with values to fill off the same pumps as factory ballast and after 5 years of total frustration I found this solution. This was the best money I have ever spent on my boat. if you have the extra ballast this is a must have. Also my tank cracked from over filling so I can empty again. this fixes all the problems that the extra ballast created. Thanks again tr6coug.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:42 AM.