Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 08-19-2013, 10:08 AM
Coffeyman76 Coffeyman76 is offline
TT Regular
 
Join Date: May 2013
Boat: MasterCraft, x45, 2006, 8.1L
Location: Southeast
Posts: 92
MC Cruise Help

Hey guys I have MC Cruise on my 2006 x45. Been trying for weeks to get it to work with no luck.

When I flip it on in MPH mode it will show the speed I am at (or 0.0 Neutral). I try to adjust the speed and it just flashes LOCK and will not adjust. RPM is the same way.

I have another MC Cruise owner on the boat and he had no idea, his doesn't say that. He just goes to Neutral, sets the speed then hits the throttle and it works perfectly.

Any ideas? I can't even really find good literature on it although admittedly I am swamped and haven't searched the forum like I should probably.

Any help appreciated! Thanks.
Reply With Quote
  #2  
Old 08-19-2013, 10:14 PM
mccobmd's Avatar
mccobmd mccobmd is offline
MC Devotee
 
Join Date: Apr 2007
Boat: Mastercraft X1 2006 310HP
Location: Oklahoma
Posts: 1,019
I find it works best when you turn the key on with it in the RPM mode and it should flash pull then set a number or RPM. On my x1 with the RTP engine 3000 RPM is about 29 miles per hour. when you start it and speed up it will flash lock until the throttle gets past your rpm setting. I have more luck leaving it in the manual mode. when you take off push the "on" and it will show an RPM, push the throttle forward and the adjust with the plus and minus, if you push quickly it is 20 rpm, hold it longer 100 RPM. It works most of the time if you set it before. I have not had much luck with MPH.
Reply With Quote
  #3  
Old 08-20-2013, 12:26 AM
Skyskiguy Skyskiguy is offline
TT Enthusiast
 
Join Date: May 2012
Boat: 2006 X30
Location: Utah
Posts: 210
Do a search on here and you will find plenty of info on MC Cruise. Some people never have any trouble with it and it works well. I never could get mine to work correctly (2006 X30 bought used in 2012). I believe that the problem lies in the speed control logic in the ECM which is written by Indmar - you'd think that with all the problems people have with it that they would be able to come up with a flash to correct the flaw in the ECM, but that has not been the case. If you have MC Cruise and it works, congratulations. If it doesn't work, call the folks at Perfect Pass and they can help you out. I ended up installing PP StarGazer and couldn't be happier.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:01 AM.