Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #1  
Old 07-26-2013, 10:30 PM
Boarded boys Boarded boys is offline
TT Newbie
 
Join Date: Jul 2013
Boat: 2011 Mastercraft x45 illmor
Location: southeast
Posts: 16
X45 won't start

my 2011 x45 ran great on Sunday afternoon. I turned it off on the lift and hooked up the engine wash down up then turned the key to turn the engine on. I got a series of clicks like the batteries were low. these are brand new state of the art Exide batteries. I plugged in the battery charger that was installed by Mastercraft. It ran 30 seconds. I went back and turned the ignition key and the boat started. I ran it for a few minutes then shut it off. I left the battery chaser plugged in and turned in for the night. I came out on MOnday and unplugged the charger. I turned the ignition key and got a click back on the starter. Nothing else. I plugged the battery charger in. It turned off. I checked the battery voltage and it was at 13 for both batteries. Fully charged. All wires tight. All fuses appeared to be good. No sign of wire disconnections or issues. I had my tech guy look around and his tests said the starter was bad. I accepted that and took the boat to the tech recommended by the Mastercraft dealer where I purchased the boat, closer to my home, and he has done Mastercraft service and warranty work. This tech removed the starter and says yes it needs to be replaced, but there is an ignition issue. he says he has spent 30 hours reviewing relays,wires etc, and can't get power from the switch to the engine. The ECM has been flashed. A loaner starter has been installed and it turns but no ignition or fuel on the engine. Any help out there?
Reply With Quote
  #2  
Old 07-27-2013, 06:39 AM
bturner2's Avatar
bturner2 bturner2 is offline
MC Devotee
 
Join Date: Mar 2008
Boat: Maristar 200VRS w/ X2 Package, 2007, 310HP
Location: Brighton, MI
Posts: 2,144
Sounds like the safety lanyard circuit or the relay on the back of the engine near the trans is bad.
Reply With Quote
  #3  
Old 07-27-2013, 12:17 PM
Boarded boys Boarded boys is offline
TT Newbie
 
Join Date: Jul 2013
Boat: 2011 Mastercraft x45 illmor
Location: southeast
Posts: 16
Thanks. The tech said the safety lanyard switch is very touchy. I will replace that first. The relay on the back of the engine is an ill more part or a mastercraft part?
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:42 AM.