Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Underwater Running Gear

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 07-20-2013, 05:44 PM
d2jp's Avatar
d2jp d2jp is offline
TT Enthusiast
 
Join Date: Jun 2011
Boat: ProStar 190, 1989, 351W
Location: VA/NC
Posts: 435
Prop 'pop' always a surprise!

I know the prop is gonna 'pop' off of the tapered shaft with a puller and a little heat, but everytime it does, and I know it's gonna happen..... but it sounds like something just broke real bad Keeping the nut on a few turns is key to preventing a big problem!

This time I followed this post and lapped the shaft/prop and it's a noticeble difference even in the feel of the fit when installing the prop. When there is a good surface-to-surface contact - you can feel the difference. Checking mine before lapping I had a pretty high area.

FYI - Prussian Blue by Permatex isn't available in NAPA, Grainer, or any parts store in my area. Even called the machine shops and engine builders and no luck. I used a large Sharpie and it worked great.
__________________
Jack
-----------------------------------------
1989 ProStar 190 Power Slot
Somewhere between SML and LKG
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 08:18 AM.