Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Engine / Drive Train

Reply
 
Thread Tools Display Modes
  #1  
Old 07-19-2013, 04:54 AM
ac505 ac505 is offline
TT Enthusiast
 
Join Date: Jul 2013
Boat: 2000 Xstar
Location: somewhere cold and wet
Posts: 139
Adding heater to 2000 TBI engine

Hi, does anybody have any pics of the feed and return line to the heater on a TBI 310hp engine pls? Assume the return will be on the up stream side of the raw waterpump, where is the pickup for the hot water on the engine pls?
Reply With Quote
  #2  
Old 07-19-2013, 07:24 PM
JohnnyB's Avatar
JohnnyB JohnnyB is online now
MC Maniac
 
Join Date: Oct 2004
Boat: 2004 Prostar 190
Location: Titletown
Posts: 2,974
Search "y-tube" and you will find a pic of the return connection. You install the y between the thru hull fitting and impeller housing 'y' upside down. You can buy the y tube on skidim.com

The hot should connect to a plug on the block next to the thermostat housing
__________________
Everyone Dies, but not everyone lives

2004 Prostar 197, ACME 843
Reply With Quote
  #3  
Old 07-19-2013, 07:28 PM
JohnnyB's Avatar
JohnnyB JohnnyB is online now
MC Maniac
 
Join Date: Oct 2004
Boat: 2004 Prostar 190
Location: Titletown
Posts: 2,974
http://www.mastercraft.com/teamtalk/...ghlight=Heater
__________________
Everyone Dies, but not everyone lives

2004 Prostar 197, ACME 843
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 01:30 PM.