Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Thread Tools Display Modes
Prev Previous Post   Next Post Next
Old 07-16-2013, 12:11 PM
etduc's Avatar
etduc etduc is offline
MC Devotee
Join Date: Jul 2004
Boat: Mastercraft Prostar 205
Location: "Jumpin' the shark"
Posts: 1,018
Originally Posted by jjbulla View Post
So I have a 1990 Prostar 190 that has been in the water for 2 weeks now. I live in the southeast and we've got a ton of ran lately (20 straight days). I've been on the boat just about every day during short dry spurts. Every time I get in the boat there is a couple inches of water in the engine compartment. The water pump has a small leak that I am going to fix this weekend, but I doubt it is dripping this much water into the boat. Anyone have any ideas on where this water could come from? Is there any chance it could be coming from the exhaust pipes? Whenever I dock it it sounds like water is getting under the exhaust caps. I can reach down and put pressure on the cap and the noise stops. Any help is greatly appreciated. I don't have pictures at this time but I will post them when I get them.
To add. Exhaust flap noise, when sitting is normal, no problem. The bilge pump, will not get bilge completely dry. Only way to do that, is on the trailer or lift with plug pulled.

2004 Red/White/Black something or other.

Formally, 1994 RED Mastercraft 205, Chevy 5.7 TBI.
Reply With Quote

engine leak, prostar, water

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -4. The time now is 10:15 PM.