Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Electrical

Reply
 
Thread Tools Display Modes
  #1  
Old 07-15-2013, 10:14 PM
MI_Corey's Avatar
MI_Corey MI_Corey is offline
MC Fanatic
 
Join Date: May 2013
Boat: 2008 X1
Location: Michigan
Posts: 525
New fuel sending unit just quit

I put a new sender in my boat a couple weeks ago. Third time out the gauge got a little below half and then just went to E and now won't work at all. Anything I should check or just a bad unit?
Reply With Quote
  #2  
Old 07-15-2013, 10:31 PM
mikeg205's Avatar
mikeg205 mikeg205 is offline
Moderator
 
Join Date: Aug 2011
Boat: 1995 Pro Star 205 5.7 Liter
Location: Plainfield - Joliet, IL
Posts: 10,927
Send a message via Skype™ to mikeg205
sounds like a bad unit to me... IMO
__________________
...A bad day water skiing still beats a good day at work...1995 Pro Star 205....
Reply With Quote
  #3  
Old 07-15-2013, 11:11 PM
charrison327's Avatar
charrison327 charrison327 is offline
TT Regular
 
Join Date: Jun 2010
Boat: 1996 ProStar 190 LT1
Location: Southeast, NC
Posts: 165
i have the same problem. replaced mine the end of last year....worked great first few trips out and now nada. after i burn my gas down to about quarter, i guess i'll slide the tank out and install a new one. actually ordering it tomorrow
__________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell

1*
Reply With Quote
  #4  
Old 07-15-2013, 11:28 PM
JMLVMI's Avatar
JMLVMI JMLVMI is offline
MC Fanatic
 
Join Date: May 2013
Boat: 2000 Prostar 195 - 350 TBI Predator, 1:1, 13x11.5 OJ 3-Blade
Location: RDU, NC
Posts: 866
Mine hasn't worked since I bought it, but I fill up every time I'm done at the lake so it has yet to be a problem. Sounds like a winter fix.
Reply With Quote
  #5  
Old 07-16-2013, 07:31 AM
charrison327's Avatar
charrison327 charrison327 is offline
TT Regular
 
Join Date: Jun 2010
Boat: 1996 ProStar 190 LT1
Location: Southeast, NC
Posts: 165
^^^^^ yeah, like you say, it's really not that big of a deal. MI_Corey, there is actually a thread on here of how to test it. if you search the maint. tips forum, there is a thread titled fuel sender 101 or something like that. it will guide you through a testing procedure if you are up for it. if it was a major undertaking, i would probably wait for the winter, but it's actually a pretty quick fix. but if i don't get around to it, i won't worry about it till later, no biggy
__________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell

1*
Reply With Quote
  #6  
Old 07-16-2013, 08:21 AM
MI_Corey's Avatar
MI_Corey MI_Corey is offline
MC Fanatic
 
Join Date: May 2013
Boat: 2008 X1
Location: Michigan
Posts: 525
Quote:
Originally Posted by charrison327 View Post
^^^^^ yeah, like you say, it's really not that big of a deal. MI_Corey, there is actually a thread on here of how to test it. if you search the maint. tips forum, there is a thread titled fuel sender 101 or something like that. it will guide you through a testing procedure if you are up for it. if it was a major undertaking, i would probably wait for the winter, but it's actually a pretty quick fix. but if i don't get around to it, i won't worry about it till later, no biggy
Ok thanks, I will search for that. Getting to my sender is very easy so I am definitely up for testing it.
Reply With Quote
  #7  
Old 07-16-2013, 08:35 AM
charrison327's Avatar
charrison327 charrison327 is offline
TT Regular
 
Join Date: Jun 2010
Boat: 1996 ProStar 190 LT1
Location: Southeast, NC
Posts: 165
took me a while to find it, but here you go

http://www.mastercraft.com/teamtalk/...ght=fuel+guage

there are a bunch of topics on fuel sender and fuel pump issues. this is the one i used on testing last year. there are a few more that are just as detailed. good luck.
__________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell

1*
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 06:02 AM.