Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #11  
Old 07-01-2013, 01:04 PM
Jerseydave's Avatar
Jerseydave Jerseydave is offline
TT Hero
 
Join Date: Jul 2004
Boat: 2005 X-STAR & 1993 Prostar 190 Limited
Location: Jersey
Posts: 5,247
Quote:
Originally Posted by Jerseydave View Post
I would start with a compression test and a leak down test. Make sure every cylinder is good. Many times "popping" out of the intake is caused by a bad camshaft, sticking intake valve or a jumped timing chain.

^ Have you done the above yet?
Also, put a timing light on it. Not sure with your distributorless ignition it this will show anything bad with the reluctor wheel.
If all else fails, hit up your nearest Corvette specialist and see what they can find.
__________________
I was njskier on here.
Reply With Quote
  #12  
Old 07-01-2013, 03:28 PM
JimN's Avatar
JimN JimN is offline
MC Master Poster
 
Join Date: Jul 2004
Posts: 11,344
Quote:
Originally Posted by glasswater View Post
I have a 1993 Mastercraft prostar 205 with the corvette multi port injection, I have replaced the engine (everything else as well) after my engine was frozen and cracked. Prior to the block cracking it was already fore firing. There was not a significant event that had made it start fore firing, it just did one day. We had hoped that by replacing the engine that if it was a mechanical problem (Cam, lifters, valves, or intake manifold) it would have worked. It did not, exactly the same problem. Idles great and only "pops" at 3,000 rpm & higher. Timing light gets dimmer and jumps around at the 3000 rpm as well.
Anyone know how I can fix this?


I have put in New Fuel pump twice, fuel filters, Intake manifold, 8 injectors, spark plugs & wires, 4 ignition coils, Ignition control module, ECM, Throttle positioning sensor (TPS), (Map) Manifold air pressure sensor -three times, three temperature sensors -many times, knock sensor, thermostats, water recirculating & Seawater pickup pumps, crankshaft positioning sensors, Engine wiring harness with all relays-Indmar had 1 harness left, (IAC) Idle air control Motor, oil pressure sensor... I'm sure Iím forgetting to mention something!

I have replaced EVERYTHING BUT:
The Reluctor Wheel
Generator/alternator -I did have it out & tested twice
MEFI 1 ECU Computer

So, help me! I can't find a mefi 1 computer. I did send it out to OBD diagnostics in California who has flashed it & installed updated info with no changes -have exactly the same results. So if anyone has any of them, let me know and I hope we could work something out. I'm also suspecting the reluctor wheel as it has a very small chip out of it. Yeah... Just very frustrated!
Is there any one who can help?
Put a white mark on the reluctor wheel where the chip is and use a timing light to see if it coincides with one of the cylinders' firing- you'll need to move the timing light's pickup from one cylinder to another to get the right one. Since this engine uses what's called "waste spark", it fires two cylinders at the same time, to burn any combustible gases in the opposite cylinder. More power and cleaner emissions. However, if the pickups see the chip in a way that it wants to fire again, it could make a difference.

Who chipped it? Are the sensors set at the correct distance from the wheel?
Reply With Quote
  #13  
Old 07-15-2013, 12:05 PM
Jerseydave's Avatar
Jerseydave Jerseydave is offline
TT Hero
 
Join Date: Jul 2004
Boat: 2005 X-STAR & 1993 Prostar 190 Limited
Location: Jersey
Posts: 5,247
Glasswater, did you ever find the cause of your problem?
__________________
I was njskier on here.
Reply With Quote
  #14  
Old 10-31-2013, 11:00 AM
gsxrjtt's Avatar
gsxrjtt gsxrjtt is offline
MC Fanatic
 
Join Date: Jan 2013
Boat: 09 X14 but that changes every month
Location: south east
Posts: 716
Where did you get the smaller CPK sensors from i can only find the long ones ??
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 11:56 PM.