Go Back   TeamTalk > General MasterCraft Topics > General Discussion

Reply
 
Thread Tools Display Modes
  #11  
Old 06-30-2013, 06:04 AM
johnnye23's Avatar
johnnye23 johnnye23 is offline
TT Regular
 
Join Date: Jun 2013
Boat: 1979 Stars n Stripes
Location: Auburn Ca
Posts: 47
Thanks guys ! Appreciate the input. I plan to order a new sending unit and gaskets to check the risers just for drill.
Reply With Quote
  #12  
Old 06-30-2013, 06:52 PM
johnnye23's Avatar
johnnye23 johnnye23 is offline
TT Regular
 
Join Date: Jun 2013
Boat: 1979 Stars n Stripes
Location: Auburn Ca
Posts: 47
Okay I have an update . While looking at all my parts removed I found that there was a hole on the intake manifold next to the large opening on the Intake manifold.But it was not present on the lower half of the thermostat housing.I drilled it out to 1/2" and completed the re-installation.Using my Fakalake the temp never went over 160 degrees. I don't know if it was a casting flaw or just that additional waterflow that did the trick.I will be taking it to the lake tomorrow. Gonna change the thread title in hopes it may help someone else.Gonna crack a cold one. I will update after my first lake outing hopefully tomorrow

Tried to upload pictures but keep getting a fail,Will try later
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 05:54 PM.