Go Back   TeamTalk > General MasterCraft Topics > General Discussion

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #26  
Old 06-19-2013, 01:56 PM
CantRepeat's Avatar
CantRepeat CantRepeat is offline
 
Join Date: Jul 2008
Boat: 06 X30
Location: Roll Tide!!
Posts: 7,585
Quote:
Originally Posted by LKGMCX30 View Post
OK. I have a similar question but couldn't find an appropriate thread.
I have an 07 MC X30 with the Indmar 350 HP engine. The boat has run fine all week. I filled up yesterday (about a half a tank's worth). We did some surfing and I noticed that I started having a hard time getting appropriate increase in RPM towing the last of our surfers on the starboard side. I had no problems with the surfers on the port side which we did first. The boat was ballasted with several FatSacs and teenagers.
After we stopped surfing and on the way home to swap boards for tubes, I was running at about 3200 RPM (28-30 MPH) and the boat suddenly went to idle. No warning lights or tones. I returned the throttle to idle and pushed it forward again and it seemed to work fine. It did it again and again thereafter. What gives? Is this a fuel filter issue, TPS, something else? I'm stumped.
I would check your fuel pressure first, but there is a thing call dead-stick on 06 MEFI4s. I'm not sure if the same issue can happen on 07 MEFI5s. I'd have to go look at a friends 07 to see if the same parts are on an 07. It happens when the ECM doesn't get a signal from the helms throttle. When this happens the ECM triggers idle. I first heard about it from EngineNut, an Indmar tech. This happens with a faulty Throttle Actuator Control (TAC) Malfunction module but I'm not sure if 07s have them. If I get a chance I'll look this weekend.

But you say you are not getting an engine alarm when it happens?
__________________
Tim
Gone, surfing.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:31 AM.