Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Restorations and Refurbishments

Reply
 
Thread Tools Display Modes
  #31  
Old 06-16-2013, 10:32 PM
Tateau18 Tateau18 is offline
TT Regular
 
Join Date: Dec 2012
Boat: 1996 Mastercraft Prostar 205
Location: Southeast
Posts: 43
Talking

I have been running the boat every weekend now with no issues after I cleaned the fuel pump inlet screen. The LT1 is definitely a power house. Can anyone with the same year or close model tell me if their check engine light comes on when the key is in the on position? I have yet to see mine come on at all and I am wondering if the bulb is out. My last boats check engine light and engine alarm would come on when the key was in the on position until the boat was started. Not having any problems here just curious if I need to swap a bulb or light. I know I definitely want it working if I ever do have a problem. Thanks for the help.
Reply With Quote
  #32  
Old 06-16-2013, 10:53 PM
Table Rocker's Avatar
Table Rocker Table Rocker is online now
MC Devotee
 
Join Date: Oct 2010
Boat: '96 ProStar 205, Sammy Duvall, LT-1
Location: Fayetteville, Arkansas
Posts: 1,647
Quote:
Originally Posted by Tateau18 View Post
I have been running the boat every weekend now with no issues after I cleaned the fuel pump inlet screen. The LT1 is definitely a power house. Can anyone with the same year or close model tell me if their check engine light comes on when the key is in the on position? I have yet to see mine come on at all and I am wondering if the bulb is out. My last boats check engine light and engine alarm would come on when the key was in the on position until the boat was started. Not having any problems here just curious if I need to swap a bulb or light. I know I definitely want it working if I ever do have a problem. Thanks for the help.
I have a '96 LT-1 and have yet to see the check engine light come on. I hope it isn't burnt out, but just doesn't come on when the key is on. Not much help, but we are in the same situation.
__________________
'96 ProStar 205 SD LT-1
Reply With Quote
  #33  
Old 06-28-2013, 10:55 AM
Schrade Schrade is offline
TT Regular
 
Join Date: Jul 2012
Boat: 1994 Prostar 205 LT1
Location: Midwest
Posts: 31
I have a 1994 LT1 PS205 and my check engine light does not come on either.
Reply With Quote
  #34  
Old 06-28-2013, 05:34 PM
jakethebt's Avatar
jakethebt jakethebt is offline
MC Fanatic
 
Join Date: Jul 2005
Boat: '96 Prostar 205 LT-1
Location: Dayton, OH
Posts: 586
'96 LT-1 here and mine never comes on either, ever.
__________________
1996 Prostar 205 LT-1
Reply With Quote
  #35  
Old 07-10-2013, 03:23 AM
charrison327's Avatar
charrison327 charrison327 is offline
TT Regular
 
Join Date: Jun 2010
Boat: 1996 ProStar 190 LT1
Location: Southeast, NC
Posts: 165
I was curious about the light as well, so pulled the panel out one day and just made a direct connection to the battery to see. worked just fine
__________________
People sleep peaceably in their beds at night only because rough men stand ready to do violence on their behalf - George Orwell

1*
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 09:53 PM.