Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > Trailers

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 05-07-2013, 01:35 AM
kgrove kgrove is offline
MC Fanatic
 
Join Date: Jun 2008
Boat: 2011 X-25
Location: Phoenix
Posts: 558
Unusual 7 pin connector

I just purchased a new to me MC and trailer and hooked it up for the first time. It's dark and I can't see for sure, but it looks like the 7 pin connector on the trailer only has 5 electrical connections. It has the slots for all 7, but there is no metal piece inside with which to make a circuit. I have running lights on the side and rear, but no left or right turn blinkers, no brake lights, and no reverse light.

Anyone else have this? Is there a reason somebody would have done this intentionally? I can see one or more of the electrodes breaking under use, but it doesn't look heavily used. On the other hand, nothing comes to mind why somebody would do this to their trailer on purpose. I don't find it possible the trailer was built this way so I likely just have to replace the 7 pin connector... I'm assuming the wires are in there somewhere and active, just not currently connected.

Now that I think about it, the previous owner did mention something about electronic brakes, but then reversed course and said he was thinking of his other trailer... Wondering if he disabled the brake lights for some reason because he had a different set up for brakes. Im not familiar with what electronic brakes even implies.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 10:12 PM.