Go Back   TeamTalk > Maintenance Tips, How-tos and Refurbishing Topics > General / Other

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #11  
Old 05-02-2013, 01:35 PM
87 TriStar 190 87 TriStar 190 is offline
TT Enthusiast
 
Join Date: Jul 2005
Posts: 149
OK, I think I have it. Last night I pulled out the dash so I could gain access to the backside of the speedo. Removed the holding bracket and was then able to pull off the tube. There was no extra length to work with and it was tight. Then disconnected the pitot pick-up tube. Lined a plastic container with white paper towel and had my wife hold the tube at the pick-up into the container. Set my air compressor at 40 psi and held that to the speedo end of the tube. No air flow at 40 psi. Being a degreed Mechanical Engineer and wanting to solve the problem, I increased the air pressure to 80 psi. Started by bumping air into the line until my wife told me things were spitting out. Removed a lot of brown slime and highly viscous fluids, along with some brown water. Continued to pressurize the systme until it was clear air. Got a lot more "snot" out than I expected. I suppose there's 26 years worth of accumulation. I bought the boat new and it's never been done before.

So, here's the next question. How do I keep this from happening again, or do I plan to make this an annual event?

Will try to post photos when I get them downloaded at home and put on here.

I think the equalizer is buried below the integral swim platform. No access that I can see actually getting at.

Now for warmer weather and the test run. Hope it works.
Reply With Quote
 

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -4. The time now is 12:29 AM.